Try the fastest and simplest way to install ONLYOFFICE

Install onlyoffice in subdirectory

Issues during installation and related to database

Install onlyoffice in subdirectory

Postby anroba » Mon Mar 07, 2016 5:43 pm

I have installed Community Server + Document Server with Docker. Everything works OK under primary domain http://www.example.com.
Now, I need offer onlyoffice under subfolder (http://www.example.com/onlyoffice), leving primary domain http://www.example.com free.

I tried to configure vpath in hyperfastcgi <vpath>/onlyoffice</vpath following
https://github.com/ONLYOFFICE/HyperFastCgi
http://www.mono-project.com/docs/web/fastcgi/
, but although I access to onlyoffice with http://www.example.com/onlyoffice, I have errors loading css styles.

I've tried changing location and rewrite in nginx, but KO, too.

Ideas?


Regards.
anroba
 
Posts: 3
Joined: Mon Mar 07, 2016 4:11 pm

Re: Install onlyoffice in subdirectory

Postby Dean » Wed Mar 09, 2016 11:29 am

Did you change a <vhost> parameter?
Dean
 
Posts: 700
Joined: Tue Sep 30, 2014 11:04 am

Re: Install onlyoffice in subdirectory

Postby Yoann » Wed Mar 09, 2016 3:28 pm

I have the same request.
How can i configure a vhost for HyperFastCgi ?

Thanks for your help,
Yoann.
Yoann
 
Posts: 27
Joined: Wed Jan 20, 2016 10:43 am

Re: Install onlyoffice in subdirectory

Postby anroba » Thu Mar 10, 2016 6:06 pm

My config hyperfastcgi

Code: Select all
# cat /etc/hyperfastcgi/
<configuration>
   <server type="HyperFastCgi.ApplicationServers.SimpleApplicationServer">
      <root-dir>/var/www/onlyoffice/WebStudio</root-dir>
   </server>
   <listener type="HyperFastCgi.Listeners.NativeListener">
      <apphost-transport type="HyperFastCgi.Transports.NativeTransport">
         <multithreading>Task</multithreading>
      </apphost-transport>
      <protocol>Unix</protocol>
      <address>//666@/var/run/onlyoffice/onlyoffice.socket</address>
   </listener>
   <apphost type="HyperFastCgi.AppHosts.AspNet.AspNetApplicationHost">
      <log level="Error" write-to-console="false" />
      <add-trailing-slash>false</add-trailing-slash>
   </apphost>
   <web-applications>
      <web-application>
         <vhost>www.example.com</vhost>
         <name>onlyoffice</name>
         <vpath>/onlyoffice</vpath>
         <path>.</path>
      </web-application>
   </web-applications>
</configuration>


I have proved with vhost name in config nginx.

Code: Select all
# cat /etc/nginx/sites-enabled/onlyoffice
...
server {
        listen 80;
        server_name http://www.example.com;

        location / {
...



but http://www.example.com/onlyoffice shows errors GET .css (error 404).

It doubles the path /onlyoffice/onlyoffice
...
example.com/onlyoffice/onlyoffice/discbundle/common/javascript/vPRcr6JGwMpxStiIujlOqg2.js?ver=264
example.com/onlyoffice/onlyoffice/discbundle/common/css/TJ43IYJIeg4VN0mKuAYOkQ2.css?ver=264
example.com/onlyoffice/onlyoffice/discbundle/common/css/oD4ITsLqSGZ4x391kk-9QA2.css?ver=264
...

Any ideas?
anroba
 
Posts: 3
Joined: Mon Mar 07, 2016 4:11 pm

Re: Install onlyoffice in subdirectory

Postby Yoann » Fri Mar 11, 2016 10:09 am

Thanks for your config.

For me, i don't get any 404 error.
I have a strange behaviour, the css files are empty with only this line :
/*
Copyright (c) Ascensio System SIA 2016. All rights reserved.
http://www.teamlab.com
*/


For this result, i make some modification in my config nginx :

server {
listen 80;
root /var/www/onlyoffice/WebStudio;
location /onlyoffice {
....


Thanks for your help,
Yoann.
Yoann
 
Posts: 27
Joined: Wed Jan 20, 2016 10:43 am

Re: Install onlyoffice in subdirectory

Postby anroba » Fri Mar 11, 2016 2:21 pm

This is my mistake too

example.com/onlyoffice/onlyoffice/discbundle/common/css/wbY5HHT1XWq4
/*
Copyright (c) Ascensio System SIA 2016. All rights reserved.
http://www.onlyoffice.com
*/
anroba
 
Posts: 3
Joined: Mon Mar 07, 2016 4:11 pm

Re: Install onlyoffice in subdirectory

Postby Yoann » Tue Mar 15, 2016 8:43 am

I think a little help would be really appreciate here :)
How can we configure properly a virtual path ?

Thanks !
Yoann.
Yoann
 
Posts: 27
Joined: Wed Jan 20, 2016 10:43 am

Re: Install onlyoffice in subdirectory

Postby Dean » Thu Mar 17, 2016 9:10 am

Our developers are checking the issue. I will contact you as soon as I get any news.
Dean
 
Posts: 700
Joined: Tue Sep 30, 2014 11:04 am

Re: Install onlyoffice in subdirectory

Postby Yoann » Fri Mar 18, 2016 7:44 am

Thanks Dean !

Yoann
Yoann
 
Posts: 27
Joined: Wed Jan 20, 2016 10:43 am

Re: Install onlyoffice in subdirectory

Postby Dean » Fri Mar 18, 2016 10:39 am

Please try to change the config files:

/var/www/onlyoffice/WebStudio/web.appsettings.config
/var/www/onlyoffice/WebStudio2/web.appsettings.config

Find the setting web.client.bundling and change its value to 'false':
Code: Select all
<add key="web.client.bundling" value="false" />
Dean
 
Posts: 700
Joined: Tue Sep 30, 2014 11:04 am

Next

Return to Installation issues

Who is online

Users browsing this forum: No registered users and 2 guests