Try the fastest and simplest way to install ONLYOFFICE

Wrong sources.list entry or malformed file

Issues during installation and related to database

Re: Wrong sources.list entry or malformed file

Postby Korbi » Wed Jan 13, 2016 3:54 pm

... Then section "Additional Requirements" surprises me:
Code: Select all
Additional Requirements
mono: version 3.2 or later
MySQL: version 5.5 or later
nginx


No need to follow "Additional Requisites" though?
In case yes and it does cause trouble - why not remove it from the instructions?
I'll give it a shot the next days on a clean server (w/o installing additional req.).
Korbi
 
Posts: 5
Joined: Wed Dec 30, 2015 11:11 pm

Re: Wrong sources.list entry or malformed file

Postby Dean » Thu Jan 14, 2016 6:26 am

This is required for developers who are compiling ONLYOFFICE from source and users who have the older prerequisites installed.
Dean
 
Posts: 700
Joined: Tue Sep 30, 2014 11:04 am

Re: Wrong sources.list entry or malformed file

Postby Korbi » Fri Jan 15, 2016 7:28 pm

Just tried it with a clean setup without installing prerequisites - problem remains the same..
Korbi
 
Posts: 5
Joined: Wed Dec 30, 2015 11:11 pm

Re: Wrong sources.list entry or malformed file

Postby Dean » Tue Jan 26, 2016 1:42 pm

Could you please describe your actions step-by-step so we could check it out?
Dean
 
Posts: 700
Joined: Tue Sep 30, 2014 11:04 am

Re: Wrong sources.list entry or malformed file

Postby Korbi » Wed Jan 27, 2016 6:41 am

Just C/Ped previous post's steps without installing prerequisites.

- Ubuntu Server, 15.10
- SWAP 4G
- sudo apt-get update

//OnlyOffice (following https://helpcenter.onlyoffice.com/de/se ... ation.aspx)
- sudo wget http://download.onlyoffice.com/repo/onlyoffice.key
- sudo apt-key add onlyoffice.key
- sudo nano /etc/apt/sources.list --> adding deb http://download.onlyoffice.com/repo/debian squeeze main
- sudo apt-get update
- sudo apt-get install onlyoffice-communityserver
Korbi
 
Posts: 5
Joined: Wed Dec 30, 2015 11:11 pm

Re: Wrong sources.list entry or malformed file

Postby Dean » Wed Feb 03, 2016 11:53 am

What is the server selected in the Software & Updates settings of the system?

Is the download.onlyoffice.com server enabled?
Dean
 
Posts: 700
Joined: Tue Sep 30, 2014 11:04 am

Re: Wrong sources.list entry or malformed file

Postby CDuv » Sat Apr 23, 2016 12:57 am

I have the same issue on a Debian 8.4 when I install the Community Server (and only Community Server, the Document Server will be on a separate server).

What I did was:
Code: Select all
wget -O -  http://download.onlyoffice.com/repo/onlyoffice.key | apt-key add -
echo "deb http://download.onlyoffice.com/repo/debian squeeze main" > /etc/apt/sources.list.d/onlyoffice.list
aptitude update
aptitude install --assume-yes onlyoffice-communityserver


I get the following error when trying to access the application via HTTP:
pplication Exception
System.Xml.XmlException
Unexpected token. Name is required here. Line 4, position 133.

Description: HTTP 500.Error processing request.
Details: Non-web exception. Exception origin (name of application or object): System.Xml.
Exception stack trace:
at Mono.Xml2.XmlTextReader.ReadAttributes (Boolean isXmlDecl) [0x00000] in <filename unknown>:0
at Mono.Xml2.XmlTextReader.ReadStartTag () [0x00000] in <filename unknown>:0
at Mono.Xml2.XmlTextReader.ReadContent () [0x00000] in <filename unknown>:0
at Mono.Xml2.XmlTextReader.Read () [0x00000] in <filename unknown>:0
at System.Xml.XmlTextReader.Read () [0x00000] in <filename unknown>:0
at System.Xml.XmlReader.Skip () [0x00000] in <filename unknown>:0
at System.Xml.XmlTextReader.Skip () [0x00000] in <filename unknown>:0
at System.Configuration.ConfigurationElement.DeserializeElement (System.Xml.XmlReader reader, Boolean serializeCollectionKey) [0x00000] in <filename unknown>:0
at System.Configuration.ConfigurationSection.DeserializeConfigSource (System.String basePath) [0x00000] in <filename unknown>:0
at System.Configuration.Configuration.GetSectionInstance (System.Configuration.SectionInfo config, Boolean createDefaultInstance) [0x00000] in <filename unknown>:0
at System.Configuration.ConfigurationSectionCollection.get_Item (System.String name) [0x00000] in <filename unknown>:0
at System.Configuration.Configuration.GetSection (System.String path) [0x00000] in <filename unknown>:0
at System.Web.Configuration.WebConfigurationManager.GetSection (System.String sectionName, System.String path, System.Web.HttpContext context) [0x00000] in <filename unknown>:0
at System.Web.Configuration.WebConfigurationManager.GetSection (System.String sectionName) [0x00000] in <filename unknown>:0
at System.Web.Configuration.HttpConfigurationSystem.System.Configuration.Internal.IInternalConfigSystem.GetSection (System.String configKey) [0x00000] in <filename unknown>:0
at System.Configuration.ConfigurationManager.GetSection (System.String sectionName) [0x00000] in <filename unknown>:0
at System.Configuration.ConfigurationManager.get_ConnectionStrings () [0x00000] in <filename unknown>:0
at ASC.Common.Data.DbRegistry.Configure () [0x00000] in <filename unknown>:0
at ASC.Common.Data.DbRegistry.GetConnectionString (System.String databaseId) [0x00000] in <filename unknown>:0
at ASC.Core.CoreContext.ConfigureCoreContextByDefault () [0x00000] in <filename unknown>:0
at ASC.Core.CoreContext..cctor () [0x00000] in <filename unknown>:0
Version Information: 3.2.8 (Debian 3.2.8+dfsg-10); ASP.NET Version: 4.0.30319.17020


All logs files in "/var/log/onlyoffice" are empty except for "nginx.access.log" which contains a HTTP 500 hit.

I am using:
* Debian 8.4 (Jessie)
* Kernel 3.16.0-4-amd64
* onlyoffice-communityserver 8.7.279-0
* nginx 1.6.2-5
* mono-complete 3.2.8+dfsg-10
CDuv
 
Posts: 1
Joined: Sat Apr 23, 2016 12:50 am

Re: Wrong sources.list entry or malformed file

Postby Dean » Mon Apr 25, 2016 12:37 pm

Please replace the string:

deb http://download.onlyoffice.com/repo/debian squeeze main

With the following one:

deb http://static.teamlab.com.s3.amazonaws.com/repo/debian squeeze main
Dean
 
Posts: 700
Joined: Tue Sep 30, 2014 11:04 am

Previous

Return to Installation issues

Who is online

Users browsing this forum: No registered users and 1 guest