Try the fastest and simplest way to install ONLYOFFICE

Wrong sources.list entry or malformed file

Issues during installation and related to database

Re: ONLYOFFICE™ Server - Linux Edition

Postby Stefan.Malin » Mon Jan 26, 2015 9:49 am

Hello there,

I'm trying to install and test OnlyOffice on debian wheezy 7.8 release.
At apt-get update command I'm receiving this message:
"W: Failed to fetch http://download.onlyoffice.com/repo/deb ... ze/Release Unable to find expected entry 'main/source/Sources' in Release file (Wrong sources.list entry or malformed file)

E: Some index files failed to download. They have been ignored, or old ones used instead."
What can go wrong?
Thanks in advance for reply.
Stefan.Malin
 
Posts: 4
Joined: Mon Jan 26, 2015 9:19 am

Re: ONLYOFFICE™ Server - Linux Edition

Postby Dean » Mon Jan 26, 2015 11:46 am

Please replace the string:

deb http://download.onlyoffice.com/repo/debian squeeze main

In the /etc/apt/sources.list with the following one:

deb http://static.teamlab.com.s3.amazonaws.com/repo/debian squeeze main
Dean
 
Posts: 700
Joined: Tue Sep 30, 2014 11:04 am

Re: ONLYOFFICE™ Server - Linux Edition

Postby Stefan.Malin » Tue Jan 27, 2015 1:24 pm

Thank you for reply.

Unfortunatelly, same issue:
"W: Failed to fetch http://static.teamlab.com.s3.amazonaws. ... ze/Release Unable to find expected entry 'main/source/Sources' in Release file (Wrong sources.list entry or malformed file)

E: Some index files failed to download. They have been ignored, or old ones used instead."

Other opinion, please?
Stefan.Malin
 
Posts: 4
Joined: Mon Jan 26, 2015 9:19 am

Re: ONLYOFFICE™ Server - Linux Edition

Postby Stefan.Malin » Tue Jan 27, 2015 1:42 pm

I have downloaded the .deb repos from http://sourceforge.net and added with dpkg.

After installation, I tried to access it with http://localhost/onlyoffice and returned Error 500.
Don't know if helps:
System.Xml.XmlException
Unexpected token. Name is required here. Line 4, position 120.

Description: HTTP 500.Error processing request.

Details: Non-web exception. Exception origin (name of application or object): System.Xml.
Exception stack trace:
at Mono.Xml2.XmlTextReader.ReadAttributes (Boolean isXmlDecl) [0x00000] in <filename unknown>:0
at Mono.Xml2.XmlTextReader.ReadStartTag () [0x00000] in <filename unknown>:0
at Mono.Xml2.XmlTextReader.ReadContent () [0x00000] in <filename unknown>:0
at Mono.Xml2.XmlTextReader.Read () [0x00000] in <filename unknown>:0
at System.Xml.XmlTextReader.Read () [0x00000] in <filename unknown>:0
at System.Xml.XmlReader.Skip () [0x00000] in <filename unknown>:0
at System.Xml.XmlTextReader.Skip () [0x00000] in <filename unknown>:0
at System.Configuration.ConfigurationElement.DeserializeElement (System.Xml.XmlReader reader, Boolean serializeCollectionKey) [0x00000] in <filename unknown>:0
at System.Configuration.ConfigurationSection.DeserializeConfigSource (System.String basePath) [0x00000] in <filename unknown>:0
at System.Configuration.Configuration.GetSectionInstance (System.Configuration.SectionInfo config, Boolean createDefaultInstance) [0x00000] in <filename unknown>:0
at System.Configuration.ConfigurationSectionCollection.get_Item (System.String name) [0x00000] in <filename unknown>:0
at System.Configuration.Configuration.GetSection (System.String path) [0x00000] in <filename unknown>:0
at System.Web.Configuration.WebConfigurationManager.GetSection (System.String sectionName, System.String path, System.Web.HttpContext context) [0x00000] in <filename unknown>:0 at System.Web.Configuration.WebConfigurationManager.GetSection (System.String sectionName) [0x00000] in <filename unknown>:0
at System.Web.Configuration.HttpConfigurationSystem.System.Configuration.Internal.IInternalConfigSystem.GetSection (System.String configKey) [0x00000] in <filename unknown>:0 at System.Configuration.ConfigurationManager.GetSection (System.String sectionName) [0x00000] in <filename unknown>:0
at System.Configuration.ConfigurationManager.get_ConnectionStrings () [0x00000] in <filename unknown>:0 at ASC.Common.Data.DbRegistry.Configure () [0x00000] in <filename unknown>:0 at ASC.Common.Data.DbRegistry.GetConnectionString (System.String databaseId) [0x00000] in <filename unknown>:0
at ASC.Core.CoreContext.ConfigureCoreContextByDefault () [0x00000] in <filename unknown>:0 at ASC.Core.CoreContext..cctor () [0x00000] in <filename unknown>:0
Stefan.Malin
 
Posts: 4
Joined: Mon Jan 26, 2015 9:19 am

Re: ONLYOFFICE™ Server - Linux Edition

Postby Dean » Fri Jan 30, 2015 1:39 pm

Try to pass the access by http://localhost:8087 then try to reach http://localhost
Please, check that you have 7 config files in /var/www/onlyoffice/Webstudio and all necessary ports are opened
Also you could try using this version https://registry.hub.docker.com/u/ascen ... monserver/
Dean
 
Posts: 700
Joined: Tue Sep 30, 2014 11:04 am

Re: ONLYOFFICE™ Server - Linux Edition

Postby Stefan.Malin » Fri Feb 06, 2015 10:51 am

Try to pass the access by http://localhost:8087 then try to reach http://localhost

Checked everything and nothing changed.
The content of onlyoffice file from /etc/nginx/sites-enabled/ is including this line "fastcgi_pass 127.0.0.1:8086" which makes me think to use http://localhost:8086 that causing a long waiting time.
Also, it looks strange to me as I found no index or index.htm or index.html file into /var/www/onlyoffice/WebStudio/ path.
So, I don't see what did I do wrong.
Stefan.Malin
 
Posts: 4
Joined: Mon Jan 26, 2015 9:19 am

Re: Wrong sources.list entry or malformed file

Postby Korbi » Wed Dec 30, 2015 11:20 pm

Did you manage to solve your problem? Just ran into the same XmlException issue on a
Code: Select all
3.19.0-31-generic #36-Ubuntu SMP Wed Oct 7 15:04:02 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

machine...
mysql, nginx pre-installed - 4G swap;
(Running onlyoffice using docker on the same machine works just fine - what am I missing here?)
Korbi
 
Posts: 5
Joined: Wed Dec 30, 2015 11:11 pm

Re: Wrong sources.list entry or malformed file

Postby Dean » Sat Jan 02, 2016 11:52 am

Hello,

what is the exact ONLYOFFICE Version and its number?

What is the name of the product you're using?
Dean
 
Posts: 700
Joined: Tue Sep 30, 2014 11:04 am

Re: Wrong sources.list entry or malformed file

Postby Korbi » Sat Jan 02, 2016 5:23 pm

I just created a new server instance - putting down all my initial steps:
- Ubuntu Server, 15.10
- SWAP 4G
- sudo apt-get update
//Mono
- sudo apt-get install mono-complete
Code: Select all
mono --version
Mono JIT compiler version 3.2.8 (Debian 3.2.8+dfsg-4ubuntu4)
Copyright (C) 2002-2014 Novell, Inc, Xamarin Inc and Contributors. www.mono-project.com
   TLS:           __thread
   SIGSEGV:       altstack
   Notifications: epoll
   Architecture:  amd64
   Disabled:      none
   Misc:          softdebug
   LLVM:          supported, not enabled.
   GC:            sgen

//mySQL
- sudo apt-get install mysql-server
- sudo mysql_install_db
- sudo /usr/bin/mysql_secure_installation
Code: Select all
mysql  Ver 14.14 Distrib 5.6.27, for debian-linux-gnu (x86_64) using  EditLine wrapper

//nginx
- sudo apt-get install nginx
- sudo service nginx start
Code: Select all
nginx -v
nginx version: nginx/1.9.3 (Ubuntu)

//OnlyOffice (following https://helpcenter.onlyoffice.com/de/se ... ation.aspx)
- sudo wget http://download.onlyoffice.com/repo/onlyoffice.key
- sudo apt-key add onlyoffice.key
- sudo nano /etc/apt/sources.list --> adding deb http://download.onlyoffice.com/repo/debian squeeze main
- sudo apt-get update
- sudo apt-get install onlyoffice-communityserver

calling server's IP I end up with:
Code: Select all
System.Xml.XmlException
Unexpected token. Name is required here.  Line 4, position 119.

Description: HTTP 500.Error processing request.
Details: Non-web exception. Exception origin (name of application or object): System.Xml.
Exception stack trace:
  at Mono.Xml2.XmlTextReader.ReadAttributes (Boolean isXmlDecl) [0x00000] in <filename unknown>:0
  at Mono.Xml2.XmlTextReader.ReadStartTag () [0x00000] in <filename unknown>:0
  at Mono.Xml2.XmlTextReader.ReadContent () [0x00000] in <filename unknown>:0
  at Mono.Xml2.XmlTextReader.Read () [0x00000] in <filename unknown>:0
  at System.Xml.XmlTextReader.Read () [0x00000] in <filename unknown>:0
  at System.Xml.XmlReader.Skip () [0x00000] in <filename unknown>:0
  at System.Xml.XmlTextReader.Skip () [0x00000] in <filename unknown>:0
  at System.Configuration.ConfigurationElement.DeserializeElement (System.Xml.XmlReader reader, Boolean serializeCollectionKey) [0x00000] in <filename unknown>:0
  at System.Configuration.ConfigurationSection.DeserializeConfigSource (System.String basePath) [0x00000] in <filename unknown>:0
  at System.Configuration.Configuration.GetSectionInstance (System.Configuration.SectionInfo config, Boolean createDefaultInstance) [0x00000] in <filename unknown>:0
  at System.Configuration.ConfigurationSectionCollection.get_Item (System.String name) [0x00000] in <filename unknown>:0
  at System.Configuration.Configuration.GetSection (System.String path) [0x00000] in <filename unknown>:0
  at System.Web.Configuration.WebConfigurationManager.GetSection (System.String sectionName, System.String path, System.Web.HttpContext context) [0x00000] in <filename unknown>:0
  at System.Web.Configuration.WebConfigurationManager.GetSection (System.String sectionName) [0x00000] in <filename unknown>:0
  at System.Web.Configuration.HttpConfigurationSystem.System.Configuration.Internal.IInternalConfigSystem.GetSection (System.String configKey) [0x00000] in <filename unknown>:0
  at System.Configuration.ConfigurationManager.GetSection (System.String sectionName) [0x00000] in <filename unknown>:0
  at System.Configuration.ConfigurationManager.get_ConnectionStrings () [0x00000] in <filename unknown>:0
  at ASC.Common.Data.DbRegistry.Configure () [0x00000] in <filename unknown>:0
  at ASC.Common.Data.DbRegistry.GetConnectionString (System.String databaseId) [0x00000] in <filename unknown>:0
  at ASC.Core.CoreContext.ConfigureCoreContextByDefault () [0x00000] in <filename unknown>:0
  at ASC.Core.CoreContext..cctor () [0x00000] in <filename unknown>:0

Version Information: 3.2.8 (Debian 3.2.8+dfsg-4ubuntu4); ASP.NET Version: 4.0.30319.17020


... installed version:
Code: Select all
apt-show-versions onlyoffice-communityserver
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
   LANGUAGE = (unset),
   LC_ALL = (unset),
   LC_PAPER = "de_DE.UTF-8",
   LC_ADDRESS = "de_DE.UTF-8",
   LC_MONETARY = "de_DE.UTF-8",
   LC_NUMERIC = "de_DE.UTF-8",
   LC_TELEPHONE = "de_DE.UTF-8",
   LC_IDENTIFICATION = "de_DE.UTF-8",
   LC_MEASUREMENT = "de_DE.UTF-8",
   LC_TIME = "de_DE.UTF-8",
   LC_NAME = "de_DE.UTF-8",
   LANG = "en_US.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to a fallback locale ("en_US.UTF-8").
onlyoffice-communityserver:all/squeeze 8.5.4-24 uptodate


As mentioned before, installing onlyoffice using docker on the same machine works flawlessly.
Any help is highly appreciated!

All the best and a happy new year to all of you,
Korbi

PS: I just saw I even got the new Linux kernel up running on 15.10 since today
Code: Select all
Linux office 4.2.0-16-generic #19-Ubuntu SMP Thu Oct 8 15:35:06 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux
Korbi
 
Posts: 5
Joined: Wed Dec 30, 2015 11:11 pm

Re: Wrong sources.list entry or malformed file

Postby Dean » Tue Jan 12, 2016 10:14 am

Hello,

There is no need to preinstall the prerequisites. All of the m will be install with ONLYOFFICE with performing the commands from this instruction.
Dean
 
Posts: 700
Joined: Tue Sep 30, 2014 11:04 am

Next

Return to Installation issues

Who is online

Users browsing this forum: Baidu [Spider] and 1 guest