Try the fastest and simplest way to install ONLYOFFICE

centos 7.2 - community server - 502 Bad Gateway issue

Issues during installation and related to database

centos 7.2 - community server - 502 Bad Gateway issue

Postby jonguo » Thu Nov 09, 2017 1:36 am

Hi all, I am looking for your help !!

As I mentioned in title, I encountered 502 bad gateway issue on my community server on and off even though I restart mono service. May I look for your help for troubleshooting? Thanks!

Here are some hints that I have right now,

1. I followed https://helpcenter.onlyoffice.com/serve ... oting.aspx instruction to disable SELinux, but the problem still exists.

/var/log/onlyoffice>sestatus
SELinux status: disabled


2. nginx logs,

127.0.0.1 - - [08/Nov/2017:15:18:43 +0800] "GET /nginx_status HTTP/1.0" 404 118218 "-" "taobot"
127.0.0.1 - - [08/Nov/2017:15:18:48 +0800] "GET /nginx_status HTTP/1.0" 404 118218 "-" "taobot"
127.0.0.1 - - [08/Nov/2017:15:19:03 +0800] "GET /nginx_status HTTP/1.0" 404 0 "-" "taobot"
127.0.0.1 - - [08/Nov/2017:15:19:18 +0800] "GET /nginx_status HTTP/1.0" 499 0 "-" "taobot"
127.0.0.1 - - [08/Nov/2017:15:19:28 +0800] "GET /nginx_status HTTP/1.0" 499 0 "-" "taobot"
127.0.0.1 - - [08/Nov/2017:15:19:43 +0800] "GET /nginx_status HTTP/1.0" 499 0 "-" "taobot"
127.0.0.1 - - [08/Nov/2017:15:19:58 +0800] "GET /nginx_status HTTP/1.0" 499 0 "-" "taobot"
127.0.0.1 - - [08/Nov/2017:15:20:13 +0800] "GET /nginx_status HTTP/1.0" 499 0 "-" "taobot"
127.0.0.1 - - [08/Nov/2017:15:20:28 +0800] "GET /nginx_status HTTP/1.0" 499 0 "-" "taobot"
127.0.0.1 - - [08/Nov/2017:15:20:43 +0800] "GET /nginx_status HTTP/1.0" 499 0 "-" "taobot"
127.0.0.1 - - [08/Nov/2017:15:20:58 +0800] "GET /nginx_status HTTP/1.0" 499 0 "-" "taobot"
127.0.0.1 - - [08/Nov/2017:15:21:03 +0800] "GET /nginx_status HTTP/1.0" 502 173 "-" "taobot"
127.0.0.1 - - [08/Nov/2017:15:21:08 +0800] "GET /nginx_status HTTP/1.0" 502 173 "-" "taobot"


2017/11/09 08:22:38 [error] 138#138: *29825 connect() to unix:/var/run/onlyoffice/onlyoffice.socket failed (11: Resource temporarily unavailable) while connecting to upstream, client: 127.0
.0.1, server: , request: "GET /nginx_status HTTP/1.0", upstream: "fastcgi://unix:/var/run/onlyoffice/onlyoffice.socket:", host: "status.taobao.com"
2017/11/09 08:22:43 [error] 138#138: *29827 connect() to unix:/var/run/onlyoffice/onlyoffice.socket failed (11: Resource temporarily unavailable) while connecting to upstream, client: 127.0
.0.1, server: , request: "GET /nginx_status HTTP/1.0", upstream: "fastcgi://unix:/var/run/onlyoffice/onlyoffice.socket:", host: "status.taobao.com"

3. nginx version is 1.12.1, community server and document server are installed in two separated machines.
jonguo
 
Posts: 1
Joined: Thu Nov 02, 2017 8:46 am

Re: centos 7.2 - community server - 502 Bad Gateway issue

Postby Maxim » Sat Nov 11, 2017 9:23 am

Hello!
Please check firewall rules.
Maxim
 
Posts: 1162
Joined: Tue Oct 11, 2016 2:34 pm


Return to Installation issues

Who is online

Users browsing this forum: No registered users and 3 guests