Try the fastest and simplest way to install ONLYOFFICE

DB Problem after apt-get install with debian9.0

Issues during installation and related to database

DB Problem after apt-get install with debian9.0

Postby norbert » Sun Jul 16, 2017 9:37 am

install on debian 9.0

-> there is an problem with dirmngr, so i had to reinstall this

apt remove gnupg
apt install --reinstall gnupg2
apt install dirmngr

apt-key adv --keyserver hkp:// --recv-keys 3FA7E0328081BFF6A14DA29AA6A19B38D3D831EF
apt-key adv --keyserver hkp:// --recv-keys CB2DE8E5

-> wrong mono version (<5.0)
add some lines for mono-complete 5.0 in sources.list, and add line for onlyoffice repo

nano /etc/apt/sources.list
deb wheezy main
deb wheezy-apache24-compat main
deb wheezy-libjpeg62-compat main

deb squeeze main

-> update and install
apt-get update
apt-get install onlyoffice-communityserver

-> the passwort that will be asked will be entered in some files with the connectionstring
but, the password into mariadb is empty. so after installation i was not able so start
onlyoffice. there was an message about "mainanance mode" on webpage

here was the problem

cat /var/log/web.07-16.log
2017-07-16 01:37:55,911 ERROR [Threadpool worker] ASC.Web - Warmup error
MySql.Data.MySqlClient.MySqlException (0x80004005): Authentication to host 'localhost' for user
'root' using method 'mysql_native_password' failed with message: Access denied for user 'root'@'localhost'
---> MySql.Data.MySqlClient.MySqlException (0x80004005): Access denied for user 'root'@'localhost'

->login to mariadb and fix the problem, it has to look like this
password was empty and the plugin was another

USE mysql;
SELECT User, Host, Password, plugin FROM mysql.user;

| User | Host | Password | plugin |
| root | localhost | *1234567890123456789012345678901234567890 | mysql_native_password |
1 row in set (0.00 sec)

-> to fix use this (use the password here, that you have entered by installing script before)

SET PASSWORD FOR 'root'@'localhost' = PASSWORD('verysecurepassword');
UPDATE user SET plugin='mysql_native_password' WHERE User='root';

it is not a real problem anymore, for me its fixed. maybe you are able to add this somewhere it helps. close the thread.

Posts: 1
Joined: Sun Jul 16, 2017 9:12 am

Re: DB Problem after apt-get install with debian9.0

Postby Maxim » Tue Jul 18, 2017 8:04 am

Hello norbert!
Thank you for the information.
We have detected the problem. We will fix it next release.
Posts: 1422
Joined: Tue Oct 11, 2016 2:34 pm

Return to Installation issues

Who is online

Users browsing this forum: No registered users and 2 guests