Try the fastest and simplest way to install ONLYOFFICE

[solved] Can't access SMTP parameters

Tech support for Enterprise Version

[solved] Can't access SMTP parameters

Postby bevito » Fri Apr 28, 2017 2:40 pm

Hi,

We're using OnlyOffice Enterprise with Docker (CP : 1.6.1.106, CS : 8.9.2.27, DS : 4.3.3.4)
Recently I discovered that email notifications did not work anymore.

So, I tried to access SMTP parameter.
The page is loading forever (you can see the attachment).

I tried to reinstall OnlyOffice (removed images), but the problem still occured.

What can I do to solve this issue ?

Best regards.
Attachments
Sélection_168.png
Sélection_168.png (25.77 KiB) Viewed 774 times
Last edited by bevito on Sat May 06, 2017 7:33 am, edited 1 time in total.
bevito
 
Posts: 26
Joined: Mon Feb 27, 2017 7:51 am

Re: Can't access SMTP parameters

Postby Maxim » Tue May 02, 2017 12:37 pm

Hello bevito!
Please specify the old image did you delete before new installation?
Maxim
 
Posts: 1179
Joined: Tue Oct 11, 2016 2:34 pm

Re: Can't access SMTP parameters

Postby bevito » Tue May 02, 2017 2:59 pm

Hi Maxim,

I used this commands :

Code: Select all
docker rm container_id


and

Code: Select all
docker rmi image_name


and I used the bash script to reinstall OnlyOffice

Code: Select all
bash enterprise-install.sh -ims false


Thanks for your help.
bevito
 
Posts: 26
Joined: Mon Feb 27, 2017 7:51 am

Re: Can't access SMTP parameters

Postby Maxim » Wed May 03, 2017 7:16 am

Hello bevito!
Please send us (private message) logs of Community Server - /app/onlyoffice/CommunityServer/logs
Maxim
 
Posts: 1179
Joined: Tue Oct 11, 2016 2:34 pm

Re: Can't access SMTP parameters

Postby bevito » Wed May 03, 2017 9:30 am

Hi Maxim,

The Community Server "logs" folder is about 1.3 Go.
Would you like all the content of this folder ?

Is there any way to configure logs rotations ?

Thanks for your answer.
bevito
 
Posts: 26
Joined: Mon Feb 27, 2017 7:51 am

Re: Can't access SMTP parameters

Postby Maxim » Thu May 04, 2017 7:25 am

Hello bevito!
We suppose that smth. happend to your database while updating or anything else.
So you should execute on host machine and then restart docker container
Code: Select all
docker exec -it onlyoffice-community-server mysql -e "UPDATE onlyoffice.core_settings SET tenant=\"-1000\" WHERE id=\"SmtpSettings\";"

I hope it will help you.
Maxim
 
Posts: 1179
Joined: Tue Oct 11, 2016 2:34 pm

Re: Can't access SMTP parameters

Postby bevito » Thu May 04, 2017 5:16 pm

Hi Maxim,

The above command gave this result :

Code: Select all
docker exec -it onlyoffice-community-server mysql -e "UPDATE onlyoffice.core_settings SET tenant=\"-1000\" WHERE id=\"SmtpSettings\";"

ERROR 1062 (23000) at line 1: Duplicate entry '-1000-SmtpSettings' for key 'PRIMARY'


Is there anything I can do to help you ?

Thanks a lot for your help and your time.
bevito
 
Posts: 26
Joined: Mon Feb 27, 2017 7:51 am

Re: Can't access SMTP parameters

Postby Maxim » Fri May 05, 2017 8:20 am

Hello bevito!
Try this
Code: Select all
docker exec -it onlyoffice-community-server mysql -e "delete from onlyoffice.core_settings WHERE id=\"SmtpSettings\";"

restart container and check SMTP parameters
Maxim
 
Posts: 1179
Joined: Tue Oct 11, 2016 2:34 pm

Re: Can't access SMTP parameters

Postby bevito » Fri May 05, 2017 10:06 am

Hi Maxim,

I just tested your command, then restart the "onlyoffice-community-server".
On our portal settings, the page is still loading forever.

What can I do to help you ?
bevito
 
Posts: 26
Joined: Mon Feb 27, 2017 7:51 am

Re: Can't access SMTP parameters

Postby bevito » Sat May 06, 2017 7:14 am

Hi Maxim,

I reinstalled OnlyOffice this morning to update all versions ( Community Server 8.9.2.2.7 -> 9.0.0.300, Control Pannel 1.6.1.106 -> 2.0.0.82)
After updating, the SMTP settings page works.

Thanks for your help.
bevito
 
Posts: 26
Joined: Mon Feb 27, 2017 7:51 am

Next

Return to Enterprise Version

Who is online

Users browsing this forum: No registered users and 1 guest