Try the fastest and simplest way to install ONLYOFFICE

High memory usage

Tech support for Enterprise Version

High memory usage

Postby Georgas » Mon Apr 17, 2017 12:37 pm

Hello,

For enterprise edition docker version in system requirements says it's minimum 6gb of ram https://helpcenter.onlyoffice.com/serve ... ments.aspx we have on server 16gb of ram and load is about 60-70% after restart, few hours later ram and swap usage are 100% it's mean 16 gb of ram and 8gb of swap . First I did install onlyoffice with mail server but after I try connect via imap and didn't work because of wrong password I uninstall mail server and setup own mail server . And I did import 2 big mailboxes 1 is about 60Gb of data another 90Gb of data , I setup it week ago can it's be that it's still importing mails so long ? Mail server is on the same server just not on the docker . I seen at email setup there was option import only 30 days emails is it mean that I won't be able to see/search through older emails or it's just mean that older emails won't be imported and can search or read them when I need through onlyoffice ?
Attachments
Screenshot at Apr 16 22-33-02.jpg
Screenshot at Apr 16 22-33-02.jpg (146 KiB) Viewed 336 times
Georgas
 
Posts: 8
Joined: Fri Apr 07, 2017 1:22 pm

Re: High memory usage

Postby Maxim » Mon Apr 17, 2017 1:19 pm

Hello Georgas!
...I uninstall mail server and setup own mail server..

Do you mean OnlyOffice Mail Server?
is it mean that I won't be able to see/search through older emails or it's just mean that older emails won't be imported and can search or read them when I need through onlyoffice ?

Yes, by default there is such limitation for emails downloading. They won't be imported but you can search them and read them. Also if a user disable this function "Import messages only for the last 30 days" than all emails would be imported.
30 days.png
30 days.png (102.63 KiB) Viewed 334 times
Maxim
 
Posts: 789
Joined: Tue Oct 11, 2016 2:34 pm

Re: High memory usage

Postby Georgas » Tue Apr 18, 2017 6:27 am

Hello Maxim,
So I deleted imap accounts and start from scratch adding only 1 account and import only emails for the last 30 days . After those emails was imported I notice that I can search and read only emails within last 30 days I can't read or search older emails . Can you tell me how long should it take to import about 60k emails ? And is it normal you seen screenshot that ram and swap 100% used ? I can't even ssh to the server without rebooting server .

Another question I have why you not allowing corporate customers to use imap connection to onlyoffice email server ? Because of that limitation I had to built mail server move all emails there and from there move all emails to onlyoffice . If we will be able to use onlyoffice imap access so it's will be enough with imapsync to sync emails to onlyoffice and thats it . But from this thread viewtopic.php?f=7&t=9473&p=13206&hilit=thunderbird#p13206 I understand it's built specially like this so people can't connect via mobile device to their email account by using onlyoffice mail server . And you ask me about deleted mail server so yes I deleted from docker onlyoffice mail server container .

For now we don't have no one user working on the program and it's using so much ram so i was wondering how much ram will need when we have 10-15 users . And if before trial ends I will be able to import all emails I have one more email account with around 90k emails which I need to have in onlyoffice as well .

Thank you
Georgas
 
Posts: 8
Joined: Fri Apr 07, 2017 1:22 pm

Re: High memory usage

Postby Maxim » Tue Apr 18, 2017 7:43 am

Hello Georgas!
I cannot see your screenshot, i see this
1.jpg
1.jpg (67.96 KiB) Viewed 321 times

Please attach your screenshot one more time.
Can you tell me how long should it take to import about 60k emails ?
    I have no idea honostly to say, it depends on many things.
And is it normal you seen screenshot that ram and swap 100% used ?
    I suppose it's not.
Send us logs please mail.agg.log You can send to support@onlyoffice.com or send me private message
for Docker - /app/onlyoffice/CommunityServer/logs
for Linux - /var/log/onlyoffice/
Also i think you should examine all processes and identify which process is using so much memory.
Maxim
 
Posts: 789
Joined: Tue Oct 11, 2016 2:34 pm

Re: High memory usage

Postby Georgas » Tue Apr 18, 2017 11:30 am

Didn't knew that you image is broken . You can see image here http://imgh.us/Screenshot_at_Apr_18_13-40-53.jpg so this screenshot I just took . It's syncs only 1 mailbox and I having again hard time open pages on the server . So yesterday I start sync it and load was about 60% as you see this morning it's already 100% ram and swap . But even when server not syncing emails load are about 60% of ram . Here I have screenshot right after server was restarted http://imgh.us/Screenshot_at_Apr_16_19-44-36.jpg . Not sure I already thinking maybe to reinstall it . Can I just delete container and reinstall it ?
Georgas
 
Posts: 8
Joined: Fri Apr 07, 2017 1:22 pm

Re: High memory usage

Postby Maxim » Tue Apr 18, 2017 2:14 pm

Georgas try next solution
1. Copy file onlyofficeMailAggregator to host machine /root
2. Run commands:
Code: Select all
docker cp /root/onlyofficeMailAggregator onlyoffice-community-server:/etc/init.d/onlyofficeMailAggregator
docker exec -it onlyoffice-community-server /etc/init.d/onlyofficeMailAggregator restart

3. Restart container
InitAggregatorScript.tar
(5.5 KiB) Downloaded 14 times
Maxim
 
Posts: 789
Joined: Tue Oct 11, 2016 2:34 pm

Re: High memory usage

Postby Georgas » Thu Apr 20, 2017 6:35 am

Hello Maxim,
Thanks for the patch, I think now all good .
Georgas
 
Posts: 8
Joined: Fri Apr 07, 2017 1:22 pm

Re: High memory usage

Postby Maxim » Thu Apr 20, 2017 7:24 am

Hello Georgas!
You are welcome! :D
Maxim
 
Posts: 789
Joined: Tue Oct 11, 2016 2:34 pm


Return to Enterprise Version

Who is online

Users browsing this forum: No registered users and 2 guests