Try the fastest and simplest way to install ONLYOFFICE

[solved] Problems with latest updates

Tech support for Enterprise Version

[solved] Problems with latest updates

Postby bevito » Mon Feb 27, 2017 8:21 am

Hi,

We updated our Docker Enterprise version this week-end.
- Control Panel : version 15.0.11 => 1.6.1.106
- Community Server : 8.9.2.27 => 8.9.2.27
- Document Server : 3.7.0.110 => 4.2.10.10

The web upgrade did not work correctly : Docker created a onlyoffice network bridge, but this network range was already used at our office.
We used "enterprise-install.sh" bash script to upgrade all the components.

We have 3 issues :

- LDAP sync does not work anymore. The error message is "Object reference not set to an instance of an object"
- Document server does not save documents. The error message : "The document could not be saved"
We checked the api url : https://<editors-dns-name>/web-apps/apps/api/documents/api.js
- My account was re-created : one with the new email format and one with the old one.

Can you help us ?

Best regards
Last edited by bevito on Sat May 06, 2017 7:34 am, edited 1 time in total.
bevito
 
Posts: 26
Joined: Mon Feb 27, 2017 7:51 am

Re: Problems with latest updates

Postby Maxim » Mon Feb 27, 2017 8:40 am

Hello bevito!
Update went wrong way! So, you should update OO by yourself using this instructions, but first please save, just in case app/onlyoffice , delete all old installation scripts, delete all your "old" containers
Code: Select all
docker ps
docker rmi [OPTIONS] IMAGE [IMAGE...]

Than install OO again follow insrtuction above using the provided script.
Maxim
 
Posts: 1224
Joined: Tue Oct 11, 2016 2:34 pm

Re: Problems with latest updates

Postby bevito » Mon Feb 27, 2017 8:48 am

Hi Maxim,

Thank you for your answer.

I think all containers are up to date :

Code: Select all
docker ps
CONTAINER ID        IMAGE                                               COMMAND                  CREATED             STATUS              PORTS                                                                                                                               NAMES
d2f3324eaa93        onlyoffice4enterprise/communityserver-ee:8.9.2.27   "/bin/sh -c 'exec ..."   2 days ago          Up 21 hours         0.0.0.0:80->80/tcp, 0.0.0.0:443->443/tcp, 3306/tcp, 5280/tcp, 9865-9866/tcp, 9871/tcp, 9882/tcp, 0.0.0.0:5222->5222/tcp, 9888/tcp   onlyoffice-community-server
12221c37fac4        onlyoffice4enterprise/controlpanel-ee:1.6.1.106     "/bin/sh -c 'bash ..."   2 days ago          Up 21 hours         80/tcp, 443/tcp                                                                                                                     onlyoffice-control-panel
875298ca0d93        onlyoffice4enterprise/documentserver-ee:4.2.10.10   "/bin/sh -c 'bash ..."   2 days ago          Up 21 hours         80/tcp, 443/tcp                                                                                                                     onlyoffice-document-server


Changing the default docker bridge network IP and onlyoffice brigde IP range resolved some issues, but not all of them.
Maybe there are some conf files that kept the old IP addresses ?

Would you still recommend to reinstall OO ?

Thanks a lot
bevito
 
Posts: 26
Joined: Mon Feb 27, 2017 7:51 am

Re: Problems with latest updates

Postby Maxim » Mon Feb 27, 2017 9:42 am

bevito wrote:Would you still recommend to reinstall OO ?
We can try to find out but it needs time, so yes - reinstall, just try....i hope it will help you.
Maxim
 
Posts: 1224
Joined: Tue Oct 11, 2016 2:34 pm

Re: Problems with latest updates

Postby bevito » Mon Feb 27, 2017 10:09 am

Hi Maxim,

Is there any procedures to reinstall OO wihout losing data ?

Thanks a lot for your time and your help.
bevito
 
Posts: 26
Joined: Mon Feb 27, 2017 7:51 am

Re: Problems with latest updates

Postby Maxim » Mon Feb 27, 2017 10:50 am

Just save app/onlyoffice and reinstall OO with provided script. After reinstallation your data will be accessible on your new installation.
Maxim
 
Posts: 1224
Joined: Tue Oct 11, 2016 2:34 pm

Re: Problems with latest updates

Postby bevito » Mon Feb 27, 2017 9:38 pm

Hi Maxim,

- OnlyOffice works now.
- LDAP Sync works too (I deleted my LDAP user account who seems to be the culprit)

Now, we have only one issue left : scrolling on files with mouse :
- On docx there is no problem.
- On pptx there is no problem.
- On xlsx, there is a problem : this is not working.
( I just tested with the default samples files provided by OnlyOffice )

Many thanks for all your help.
bevito
 
Posts: 26
Joined: Mon Feb 27, 2017 7:51 am

Re: Problems with latest updates

Postby Maxim » Tue Feb 28, 2017 7:36 am

bevito wrote:...- On xlsx, there is a problem : this is not working.
( I just tested with the default samples files provided by OnlyOffice )....

Please specify what errors do you see? Describe in details your issue please.
Maxim
 
Posts: 1224
Joined: Tue Oct 11, 2016 2:34 pm

Re: Problems with latest updates

Postby bevito » Tue Feb 28, 2017 8:23 am

Hi Maxim,

When i open xlsx files, I can't scroll up and down with wheel's mouse.
It works on docx and pptx.

I have no erros on screen.

Thanks a lot for your help.
bevito
 
Posts: 26
Joined: Mon Feb 27, 2017 7:51 am

Re: Problems with latest updates

Postby Maxim » Wed Mar 01, 2017 11:48 am

Hello bevito!
We try to reproduce the issue but have no luck unfortunately. Try to stop containers and start again.
Maxim
 
Posts: 1224
Joined: Tue Oct 11, 2016 2:34 pm

Next

Return to Enterprise Version

Who is online

Users browsing this forum: No registered users and 1 guest