Try the fastest and simplest way to install ONLYOFFICE

URL Issues 404, 501 and 504

Tech support for Enterprise Version

URL Issues 404, 501 and 504

Postby kiar » Tue Oct 04, 2016 8:29 am

Hello,

I've installed successfully the enterprise version on a debian jessie server with this script : http://helpcenter.onlyoffice.com/server ... ation.aspx
https + domain is also configured : I can access all tools from OnlyOffice, but there are some issues, and I don't find the origin :

  • Document Editing is ok, but I cannot save the document, spellcheck also don't work :

    Code: Select all
    https://oo.domain.com/2016-09-26-10-13/web-apps/apps/documenteditor/main/resources/help/fr/Contents.json Failed to load resource: the server responded with a status of 404 (Not Found)
    https://oo.domain.com/spellchecker/doc/gkpWIjkaIi3ovhMhXY0_/c/851/4ut4t0mp/xhr_streaming?t=1475568506244 504 (Gateway Time-out)
    Uncaught ReferenceError: SockJS is not defined
    POST https://oo.domain.com/spellchecker/doc/gkpWIjkaIi3ovhMhXY0_/c/920/l1zttpph/xhr_streaming?t=1475568616352 504 (Gateway Time-out)
    POST https://oo.domain.com/doc/gkpWIjkaIi3ovhMhXY0_/c/817/q4wowjev/xhr_send?t=1475568681533 404 (Not Found)
  • Same problem with some parameters : portal rename or theme change :

    Code: Select all
    https://oo.domain.com/api/2.0/portal/portalrename.json?__=603930 501 (Not Implemented)
    https://oo.domain.Com/api/2.0/settings/colortheme.json?__=343349 501 (Not Implemented)

    
  • Same problem with the feed :

    Code: Select all
    https://oo.domain.com/api/2.0/feed/read.json?__=993246 501 (Not Implemented)

On the server :

Code: Select all
# docker ps
CONTAINER ID        IMAGE                                                COMMAND                  CREATED             STATUS              PORTS                                                                                                                               NAMES
a0e91d411b4b        onlyoffice4enterprise/communityserver-ee:8.9.1.191   "/bin/sh -c 'exec dum"   12 hours ago        Up 12 hours         0.0.0.0:80->80/tcp, 0.0.0.0:443->443/tcp, 3306/tcp, 5280/tcp, 9865-9866/tcp, 9871/tcp, 9882/tcp, 0.0.0.0:5222->5222/tcp, 9888/tcp   onlyoffice-community-server
389774a70bfa        onlyoffice4enterprise/controlpanel-ee:1.6.0.64       "/bin/sh -c 'bash -C "   40 hours ago        Up 12 hours         80/tcp, 443/tcp                                                                                                                     onlyoffice-control-panel
c4e8d07c093e        onlyoffice4enterprise/documentserver-ee:4.1.3.3      "/bin/sh -c 'bash -C "   40 hours ago        Up 11 hours         80/tcp, 443/tcp                                                                                                                     onlyoffice-document-server


For the document service parameter, I always gave the FQDN, example for Document Editing Service Address : https://oo.domain.com/OfficeWeb/apps/ap ... nts/api.js

I didn't find any helpful information in the logs.
Maybe I've unseen some point in the documentation, but I don't get it, any idea to solve the problem ?

Thanks
kiar
 
Posts: 23
Joined: Tue Oct 04, 2016 7:31 am

Re: URL Issues 404, 501 and 504

Postby Eugenie » Thu Oct 06, 2016 11:07 am

Hello,

First of all, please go Settings>>Integration>>Document Service and change address in the line "Community Server Address" to your IP address (or to your domain address if IP is indicated at the moment).

If it does not solve the issue, please send us a screenshot showing Settings you have chosen.
Eugenie
 
Posts: 134
Joined: Mon Aug 25, 2014 10:11 am

Re: URL Issues 404, 501 and 504

Postby kiar » Thu Oct 06, 2016 8:41 pm

Hello Eugenie,

Thanks for the answer, I understand what you mean, and my tests today just confirm it. I have to explain a little more our configuration.
OnlyOffice is installed in a local network, and the errors are thrown when I try to access it from outside.
There is no issue when I access OnlyOffice from the local network, and that's pretty good news.

I saw this page : https://helpcenter.onlyoffice.com/serve ... erver.aspx
This explain the configuration for local/public network, but unfortunately I don't know what to insert for the Community Server Address ( local ip from OnlyOffice ? domain name ? extern IP from the main server - not OnlyOffice ? ).

This is our configuration yet :

Document Editing Service Address
https://oo.domain.com/OfficeWeb/apps/ap ... nts/api.js

Document Command Service Address
https://oo.domain.com/coauthoring/CommandService.ashx

Document Storage Service Address
https://oo.domain.com/FileUploader.ashx

Document Conversion Service Address
https://oo.domain.com/ConvertService.ashx

Community Server Address
https://oo.domain.com

I tried the local ip and the public ip for the Community Server Address, and it throw a 500 error.
Maybe should I only give the local ip for the other adress ? I mean Document Storage Service Address, Document Storage Service Address, ...
kiar
 
Posts: 23
Joined: Tue Oct 04, 2016 7:31 am

Re: URL Issues 404, 501 and 504

Postby kiar » Sun Oct 09, 2016 6:57 pm

Hello,

This error is solved :

Code: Select all
https://oo.domain.com/2016-09-26-10-13/web-apps/apps/documenteditor/main/resources/help/fr/Contents.json Failed to load resource: the server responded with a status of 404 (Not Found)


The problem was, that on documentserver the directory /var/www/onlyoffice/documentserver/web-apps/apps/documenteditor/main/resources/help/only have 2 subdirectory "en" and "ru", but not "fr".
Maybe it is the same problem for the other issue ? The language "fr" is maybe not completely installed ?
kiar
 
Posts: 23
Joined: Tue Oct 04, 2016 7:31 am

Re: URL Issues 404, 501 and 504

Postby kiar » Mon Oct 17, 2016 9:12 am

Hello,

This is not a issue with OnlyOffice.
The problems are due to our Loadbalancer, Pound. Pound can't handle the websockets properly and cause a lost connection.
A solution may be to replace Pound with Haproxy, but I didn't find the time to do it.
It would be a nice and save my time if someone can confirm that Pound can't support OnlyOffice, but Haproxy can.
kiar
 
Posts: 23
Joined: Tue Oct 04, 2016 7:31 am


Return to Enterprise Version

Who is online

Users browsing this forum: No registered users and 1 guest