Page 1 of 1

Control Panel Problem

PostPosted: Mon Feb 05, 2018 2:59 pm
by domcom
Hello.
I have my OnlyOffice installation on a Ubuntu xenial Server with the Docker installation script.
After setting up the SSL Settings i cound't connect to the Control Panel. When i try to connect i get the Message "
"Sorry, the resource
cannot be found."
I have tried to search for the reaon for myself but i cannot find the Webserver on the Control Panel, or any usfull logs.

Can someone here help me with my problem?

Greeting
DomCom

Re: Control Panel Problem

PostPosted: Wed Feb 07, 2018 12:44 pm
by Maxim
Hello domcom!
After setting up the SSL Settings

What exactly you did.
Is control panel container running?

Re: Control Panel Problem

PostPosted: Wed Feb 07, 2018 2:54 pm
by domcom
Hello Maxim.

First i tried to set up the ssl Connection via the Control Panel, when this didn't work(the website wouldn't start up again) i tried the way of copy the Certificat in to the /app/onlyoffice/***/data/certs/
This seemed worked for the internal network but as soon as i tried to connect from the Internet, i coudn't open/download/delete files on the Server.
So i took a look at the webserver configuration and found that the Document Server didn't had the ssl Config activ, so i did it by hand and changed a rewrite that didn't worked.
from
rewrite ^ https://$host$request_uri? permanent;
to
rewrite ^ https://localhost$request_uri? permanent;

After this changes i could access the Document ond Community Server without problem, only the Control Panel is not accessable.

The Control Panel Server/Container is running.

Re: Control Panel Problem

PostPosted: Mon Feb 12, 2018 11:39 am
by Maxim
Hello domcom!
I suppose that something wrong with your configuration. If you installed Onlyoffice Enterprise Edition you should put your existing SSL certs via Control Panel and restart Community Server container (or restart monoserve service+nginx service in community server container) or you can manually put them (certs) into
/app/onlyoffice/Communityserver/data/certs
and restart container.
Community Server is a proxy server for Document Server and Control Panel. You do not need to configure them. If it doesn't work it means that your installation is not correct.
I advice you to reinstall docker version correctly using installation script.

Re: Control Panel Problem

PostPosted: Mon Feb 26, 2018 8:28 am
by domcom
Ok, i found the problem. It was so simple, that i overlooked it the whole time.
The solution was, that in the Community Server Docker, the include onlyoffice-communityserver-proxy-to-controlpanel.conf.template had to be copied to onlyoffice-communityserver-proxy-to-controlpanel.conf and fill in the IP-Adress of the Control Panel in the proxy_pass.
After that i just had to restart the nginx and the Control Panel was online.

Re: Control Panel Problem

PostPosted: Mon Feb 26, 2018 12:54 pm
by Maxim
Hello domcom!
That's great!