Try the fastest and simplest way to install ONLYOFFICE

[Community Server] WebDav and Nuxeo

Tech support for Enterprise Version

[Community Server] WebDav and Nuxeo

Postby dsi-lille » Mon Jan 15, 2018 10:08 am

Hello,

the original topic is here : viewtopic.php?f=3&t=6752
Please, read it before continue !

My mistake, i discovered that you had overwriting some methods of the SharpBox library.
Upgrading the library may not be the answer and could be lot of work for you.

So i debugged your version of sharpbox and i found why i have a null exception

The problem is here :

Code: Select all
var resourceType = prop.Element(XName.Get("resourcetype", DavNamespace));


Nuxeo WebDav doesn't include resourcetype element in it's answer, so resourceType variable is null and with this line :

Code: Select all
if (resourceType.Element(XName.Get("collection", DavNamespace)) != null)


We get a nice System.NullReferenceException: Object reference not set to an instance of an object

Could you, please, fix this ?

Thanks a lot !
Yoann

PS : The orignal sharpbox library works with the webdav of Nuxeo
dsi-lille
 
Posts: 200
Joined: Mon Jul 11, 2016 1:47 pm

Re: [Community Server] WebDav and Nuxeo

Postby Maxim » Wed Jan 17, 2018 8:43 am

Hello Yaonn!
Great thanks for your feedback!
I have redirected this info to our developers.
Could you, please, fix this ?

We will but i cannot say when.
Maxim
 
Posts: 1732
Joined: Tue Oct 11, 2016 2:34 pm

Re: [Community Server] WebDav and Nuxeo

Postby dsi-lille » Wed Jan 17, 2018 9:34 am

Hello Maxim,

thanks for your answer !

Yoann.
dsi-lille
 
Posts: 200
Joined: Mon Jul 11, 2016 1:47 pm

Re: [Community Server] WebDav and Nuxeo

Postby Maxim » Wed Jan 17, 2018 1:10 pm

Hello Yoann!
Please specify your version Nuxeo Platform and server's OS.
We found out that due to this bug there is no possibility to connect Onlyoffice to Nuxeo Platform using WebDAV.
Maxim
 
Posts: 1732
Joined: Tue Oct 11, 2016 2:34 pm

Re: [Community Server] WebDav and Nuxeo

Postby dsi-lille » Wed Jan 17, 2018 1:40 pm

Hello Maxim,

We use Nuxeo 6.0 with all the hotfix.
This bug concern only Nuxeo 9.

Anyway, i used the source of your sharbox library (with all your modification) and i run a unit test with Microsoft Visual Studio.
Trust me, the problem is really located here ;)

Thanks,
Yoann
dsi-lille
 
Posts: 200
Joined: Mon Jul 11, 2016 1:47 pm

Re: [Community Server] WebDav and Nuxeo

Postby dsi-lille » Fri Mar 16, 2018 9:50 am

Hello Maxim,

any news about this ?

Thanks,
Yoann.
dsi-lille
 
Posts: 200
Joined: Mon Jul 11, 2016 1:47 pm

Re: [Community Server] WebDav and Nuxeo

Postby Maxim » Fri Mar 16, 2018 10:40 am

Hello Yoann!
Yes, but i cannot say when we are going to fix it. Developers are overloaded for now.
But i hope it will be fixed soon.
Maxim
 
Posts: 1732
Joined: Tue Oct 11, 2016 2:34 pm

Re: [Community Server] WebDav and Nuxeo

Postby dsi-lille » Fri Mar 16, 2018 1:56 pm

No problem.
Thanks for your answer !

Yoann
dsi-lille
 
Posts: 200
Joined: Mon Jul 11, 2016 1:47 pm

Re: [Community Server] WebDav and Nuxeo

Postby Maxim » Tue Jul 17, 2018 8:19 am

Hello dsi-lille!
We have fixed this issue in 10th Community Server version.
Maxim
 
Posts: 1732
Joined: Tue Oct 11, 2016 2:34 pm

Re: [Community Server] WebDav and Nuxeo

Postby dsi-lille » Tue Jul 17, 2018 8:27 am

Hello Maxim,

great news !
Thanks a lot :)

Yoann.
dsi-lille
 
Posts: 200
Joined: Mon Jul 11, 2016 1:47 pm


Return to Enterprise Version

Who is online

Users browsing this forum: No registered users and 2 guests

cron