Try the fastest and simplest way to install ONLYOFFICE

Periodical server (or just webserver ) hangs.

Tech support for Enterprise Version

Periodical server (or just webserver ) hangs.

Postby rudais » Thu Oct 12, 2017 5:12 am

Hello,

I in recent month have started encountering problem that server or just the webserver hangs after a while a week or two. System reboot helps. Problem being that OO no longer responds to web requests.

For now I have just given the VM on which server is installed more resources just to be on the safe side that it just inst related to lack of resources. I will be monitoring it more closely now.

Where should I start looking for source of these hangs? When digging around in forum I found that logs for docker are located here: "/app/onlyoffice/CommunityServer/logs".

For which services I should be looking for in docker when such situation occurs again?

Some details on system that I am running the server on:

== VM on KVM(proxmox):
- CPU: 4 cores
- RAM: 7-10GB
- Disk: virtio 50Gigs on SSD raid

- OS: Ubuntu Server v16.04.3, Docker v17.06.0-ce
- Only Office is running on docket installation: Control Panel, Community and Documents servers are all updated to latest
rudais
 
Posts: 9
Joined: Mon Oct 02, 2017 11:14 am

Re: Periodical server (or just webserver ) hangs.

Postby Maxim » Tue Oct 17, 2017 5:46 am

Hello rudais!
You can review all of them cause you do not know what exactly works wrong i suppose and search for ERROR, ngnix logs should be checked at first.
Maxim
 
Posts: 1072
Joined: Tue Oct 11, 2016 2:34 pm

Re: Periodical server (or just webserver ) hangs.

Postby rudais » Tue Oct 17, 2017 2:10 pm

Thanks for comment. I will check those logs if problem occurs again.
rudais
 
Posts: 9
Joined: Mon Oct 02, 2017 11:14 am


Return to Enterprise Version

Who is online

Users browsing this forum: No registered users and 1 guest

cron