Try the fastest and simplest way to install ONLYOFFICE

[Control Panel] Backup function doesn't work

Tech support for Enterprise Version

[Control Panel] Backup function doesn't work

Postby dsi-lille » Fri May 19, 2017 11:38 am

Hello,

in control panel when i try to do a backup, i get this error on the interface :

controlpanel_backup1.jpg
controlpanel_backup1.jpg (6.01 KiB) Viewed 43 times


in the log :

Code: Select all
2017-05-19 13:18:20,429 ERROR [Threadpool worker] ASC.Api - method error: https://127.0.0.1/api/2.0/portal/getBackupProgress.json - Server error
System.ServiceModel.EndpointNotFoundException: System error. ---> System.Net.WebException: Error: ConnectFailure (Connection refused) ---> System.Net.Sockets.SocketException: Connection refused
  at System.Net.Sockets.Socket.Connect (System.Net.EndPoint remoteEP) [0x000d1] in <5641e4edad4f4464ba58c620a7b8ea48>:0
  at System.Net.WebConnection.Connect (System.Net.HttpWebRequest request) [0x0019b] in <5641e4edad4f4464ba58c620a7b8ea48>:0
   --- End of inner exception stack trace ---
  at System.Net.HttpWebRequest.EndGetRequestStream (System.IAsyncResult asyncResult) [0x00043] in <5641e4edad4f4464ba58c620a7b8ea48>:0
  at System.ServiceModel.Channels.HttpRequestChannel+<BeginProcessRequest>c__AnonStorey1.<>m__0 (System.IAsyncResult r) [0x0001d] in <abc049434133440d8dd6b5b31f2f4992>:0
   --- End of inner exception stack trace ---
  at <0x00000 + 0x00000> <unknown method>
  at (wrapper remoting-invoke) ASC.Core.Common.Contracts.IBackupService:GetBackupProgress (int)
  at ASC.Core.Common.Contracts.BackupServiceClient.GetBackupProgress (System.Int32 tenantId) [0x00006] in <b59e83b0deed4374bcc144b5c9886710>:0
  at ASC.Web.Studio.Core.Backup.BackupAjaxHandler.GetBackupProgress () [0x00011] in <886a8c8358834ea5a6b42a3d8a06c2c6>:0
  at ASC.Api.Portal.PortalApi.GetBackupProgress () [0x00000] in <2851f2826b594aa79a12c210de65cc6d>:0
  at (wrapper managed-to-native) System.Reflection.MonoMethod:InternalInvoke (System.Reflection.MonoMethod,object,object[],System.Exception&)
  at System.Reflection.MonoMethod.Invoke (System.Object obj, System.Reflection.BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) [0x00038] in <dbb16e0bacdc4a0f87478e401bc29b6c>:0



We have 2600 users and around 89Go of data.

Thanks for your help,
Yoann.
dsi-lille
 
Posts: 88
Joined: Mon Jul 11, 2016 1:47 pm

Re: [Control Panel] Backup function doesn't work

Postby Maxim » Mon May 22, 2017 9:11 am

Hello Yoann!
You need to enter the Community Server container and enable detailed log in /var/www/onlyoffice/Services/TeamlabSvc/
find TeamLabSvc.exe.Config and change value "DEBUG" to "ALL"
Code: Select all
 <logger name="ASC">
      <appender-ref ref="File" />
      <appender-ref ref="Console" />
      <level value="DEBUG" />
    </logger>

it should be like this
Code: Select all
 <logger name="ASC">
      <appender-ref ref="File" />
      <appender-ref ref="Console" />
      <level value="ALL" />
    </logger>

restart service onlyofficeBackup
repeat the operation of backup creating
and send us logs please.
Maxim
 
Posts: 663
Joined: Tue Oct 11, 2016 2:34 pm

Re: [Control Panel] Backup function doesn't work

Postby dsi-lille » Tue May 23, 2017 7:51 am

Hello,

you can find svcBackup log here : https://filesender.renater.fr/?s=downlo ... 74&lang=en

and always this error from web.api log :

Code: Select all
2017-05-23 09:39:46,583 ERROR [Threadpool worker] ASC.Api - method error: https://127.0.0.1/api/2.0/portal/getBackupProgress.json - Server error
System.ServiceModel.EndpointNotFoundException: System error. ---> System.Net.WebException: Error: ConnectFailure (Connection refused) ---> System.Net.Sockets.SocketException: Connection refused
  at System.Net.Sockets.Socket.Connect (System.Net.EndPoint remoteEP) [0x000d1] in <5641e4edad4f4464ba58c620a7b8ea48>:0
  at System.Net.WebConnection.Connect (System.Net.HttpWebRequest request) [0x0019b] in <5641e4edad4f4464ba58c620a7b8ea48>:0
   --- End of inner exception stack trace ---
  at System.Net.HttpWebRequest.EndGetRequestStream (System.IAsyncResult asyncResult) [0x00043] in <5641e4edad4f4464ba58c620a7b8ea48>:0
  at System.ServiceModel.Channels.HttpRequestChannel+<BeginProcessRequest>c__AnonStorey1.<>m__0 (System.IAsyncResult r) [0x0001d] in <abc049434133440d8dd6b5b31f2f4992>:0
   --- End of inner exception stack trace ---
  at <0x00000 + 0x00000> <unknown method>
  at (wrapper remoting-invoke) ASC.Core.Common.Contracts.IBackupService:GetBackupProgress (int)
  at ASC.Core.Common.Contracts.BackupServiceClient.GetBackupProgress (System.Int32 tenantId) [0x00006] in <b59e83b0deed4374bcc144b5c9886710>:0
  at ASC.Web.Studio.Core.Backup.BackupAjaxHandler.GetBackupProgress () [0x00011] in <886a8c8358834ea5a6b42a3d8a06c2c6>:0
  at ASC.Api.Portal.PortalApi.GetBackupProgress () [0x00000] in <2851f2826b594aa79a12c210de65cc6d>:0
  at (wrapper managed-to-native) System.Reflection.MonoMethod:InternalInvoke (System.Reflection.MonoMethod,object,object[],System.Exception&)
  at System.Reflection.MonoMethod.Invoke (System.Object obj, System.Reflection.BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) [0x00038] in <dbb16e0bacdc4a0f87478e401bc29b6c>:0


Thanks for your help,
Yoann
dsi-lille
 
Posts: 88
Joined: Mon Jul 11, 2016 1:47 pm

Re: [Control Panel] Backup function doesn't work

Postby dsi-lille » Tue May 23, 2017 8:01 am

Just launch a second save and get (maybe) a better error in svcbackup log :

Code: Select all
2017-05-23 09:56:52,788 WARN  [7] ASC.Backup - backup attempt failure: System.ArgumentException: Couldn't store <2/26/2017 11:12:14 PM> in date Column.  Expected type is DateTime. ---> System.Threading.ThreadAbortException
  at System.Data.Common.DateTimeStorage.Set (System.Int32 record, System.Object value) [0x00106] in <acd8058a155649249a9fcf2f89526586>:0
  at System.Data.DataColumn.set_Item (System.Int32 record, System.Object value) [0x00000] in <acd8058a155649249a9fcf2f89526586>:0
   --- End of inner exception stack trace ---
  at System.Data.DataColumn.set_Item (System.Int32 record, System.Object value) [0x00027] in <acd8058a155649249a9fcf2f89526586>:0
  at System.Data.DataTable.NewRecordFromArray (System.Object[] value) [0x00042] in <acd8058a155649249a9fcf2f89526586>:0
2017-05-23 09:56:53,808 ERROR [7] ASC.Backup - RunJob - Params: { Id = 79ae057c-d417-47be-9a0a-8f90acb8c381, Tenant = 2, File = /var/www/onlyoffice/Data/Backup/localhost_2017-05-23_07-55-24.tar.gz, BasePath = 20 }, Error = System.Threading.ThreadAbortException
  at ASC.Data.Backup.ActionInvoker.Try (System.Action`1[T] action, System.Object state, System.Int32 maxAttempts, System.Action`1[T] onFailure, System.Action`1[T] onAttemptFailure, System.Int32 sleepMs, System.Boolean isSleepExponential) [0x0006c] in <9ea55207ad0b4553b354ed5c1502fd5a>:0
  at ASC.Data.Backup.Tasks.BackupPortalTask.DoBackupModule (ASC.Data.Backup.IDataWriteOperator writer, ASC.Data.Backup.Tasks.DbFactory dbFactory, ASC.Data.Backup.Tasks.Modules.IModuleSpecifics module) [0x000f6] in <9ea55207ad0b4553b354ed5c1502fd5a>:0
  at ASC.Data.Backup.Tasks.BackupPortalTask.RunJob () [0x0007d] in <9ea55207ad0b4553b354ed5c1502fd5a>:0
  at ASC.Data.Backup.Service.BackupWorker+BackupProgressItem.RunJob () [0x000a7] in <9ea55207ad0b4553b354ed5c1502fd5a>:0
dsi-lille
 
Posts: 88
Joined: Mon Jul 11, 2016 1:47 pm

Re: [Control Panel] Backup function doesn't work

Postby dsi-lille » Tue May 23, 2017 8:07 am

Third attempt, and an another error from svcbackup log :

Code: Select all
2017-05-23 10:03:59,310 WARN  [6] ASC.Backup - backup attempt failure: System.Threading.ThreadAbortException
  at MySql.Data.MySqlClient.MySqlTrace.LogWarning (System.Int32 id, System.String msg) [0x00028] in <c26034d9edd24c84a9d9322b4dd5be57>:0
  at MySql.Data.MySqlClient.MySqlConnection.HandleTimeoutOrThreadAbort (System.Exception ex) [0x00077] in <c26034d9edd24c84a9d9322b4dd5be57>:0
  at (wrapper remoting-invoke-with-check) MySql.Data.MySqlClient.MySqlConnection:HandleTimeoutOrThreadAbort (System.Exception)
  at MySql.Data.MySqlClient.MySqlDataReader.Read () [0x00046] in <c26034d9edd24c84a9d9322b4dd5be57>:0
  at System.Data.ProviderBase.DataReaderContainer.Read () [0x00000] in <acd8058a155649249a9fcf2f89526586>:0
  at System.Data.Common.DataAdapter.FillLoadDataRow (System.Data.ProviderBase.SchemaMapping mapping) [0x00073] in <acd8058a155649249a9fcf2f89526586>:0
  at System.Data.Common.DataAdapter.FillFromReader (System.Data.DataSet dataset, System.Data.DataTable datatable, System.String srcTable, System.Data.ProviderBase.DataReaderContainer dataReader, System.Int32 startRecord, System.Int32 maxRecords, System.Data.DataColumn parentChapterColumn, System.Object parentChapterValue) [0x00089] in <acd8058a155649249a9fcf2f89526586>:0
  at System.Data.Common.DataAdapter.Fill (System.Data.DataTable[] dataTables, System.Data.IDataReader dataReader, System.Int32 startRecord, System.Int32 maxRecords) [0x00114] in <acd8058a155649249a9fcf2f89526586>:0
  at System.Data.Common.DbDataAdapter.FillInternal (System.Data.DataSet dataset, System.Data.DataTable[] datatables, System.Int32 startRecord, System.Int32 maxRecords, System.String srcTable, System.Data.IDbCommand command, System.Data.CommandBehavior behavior) [0x00052] in <acd8058a155649249a9fcf2f89526586>:0
  at System.Data.Common.DbDataAdapter.Fill (System.Data.DataTable[] dataTables, System.Int32 startRecord, System.Int32 maxRecords, System.Data.IDbCommand command, System.Data.CommandBehavior behavior) [0x00097] in <acd8058a155649249a9fcf2f89526586>:0
  at System.Data.Common.DbDataAdapter.Fill (System.Data.DataTable dataTable) [0x00030] in <acd8058a155649249a9fcf2f89526586>:0
  at (wrapper remoting-invoke-with-check) System.Data.Common.DbDataAdapter:Fill (System.Data.DataTable)
  at ASC.Data.Backup.Tasks.BackupPortalTask+<DoBackupModule>c__AnonStorey0.<>m__0 (System.Object state) [0x00064] in <9ea55207ad0b4553b354ed5c1502fd5a>:0
  at ASC.Data.Backup.ActionInvoker.Try (System.Action`1[T] action, System.Object state, System.Int32 maxAttempts, System.Action`1[T] onFailure, System.Action`1[T] onAttemptFailure, System.Int32 sleepMs, System.Boolean isSleepExponential) [0x00018] in <9ea55207ad0b4553b354ed5c1502fd5a>:0
2017-05-23 10:04:00,331 ERROR [6] ASC.Backup - RunJob - Params: { Id = 1bf488eb-7774-4679-ad1f-84d309b28709, Tenant = 2, File = /var/www/onlyoffice/Data/Backup/localhost_2017-05-23_08-02-29.tar.gz, BasePath = 20 }, Error = System.Threading.ThreadAbortException
  at ASC.Data.Backup.ActionInvoker.Try (System.Action`1[T] action, System.Object state, System.Int32 maxAttempts, System.Action`1[T] onFailure, System.Action`1[T] onAttemptFailure, System.Int32 sleepMs, System.Boolean isSleepExponential) [0x0006c] in <9ea55207ad0b4553b354ed5c1502fd5a>:0
  at ASC.Data.Backup.Tasks.BackupPortalTask.DoBackupModule (ASC.Data.Backup.IDataWriteOperator writer, ASC.Data.Backup.Tasks.DbFactory dbFactory, ASC.Data.Backup.Tasks.Modules.IModuleSpecifics module) [0x000f6] in <9ea55207ad0b4553b354ed5c1502fd5a>:0
  at ASC.Data.Backup.Tasks.BackupPortalTask.RunJob () [0x0007d] in <9ea55207ad0b4553b354ed5c1502fd5a>:0
  at ASC.Data.Backup.Service.BackupWorker+BackupProgressItem.RunJob () [0x000a7] in <9ea55207ad0b4553b354ed5c1502fd5a>:0
dsi-lille
 
Posts: 88
Joined: Mon Jul 11, 2016 1:47 pm

Re: [Control Panel] Backup function doesn't work

Postby Maxim » Tue May 23, 2017 11:23 am

Hello Yoann!
It needs to execute next request
Code: Select all
mysql -u root -D onlyoffice -e "select id, date from login_events order by date asc;" > login_events.csv


This request saves data from table login_events into the file login_events.csv Root as a user, database is onlyoffice, no password. If you have changed while installation please use current settings.
After that send us please the results (login_events.csv)
Maxim
 
Posts: 663
Joined: Tue Oct 11, 2016 2:34 pm

Re: [Control Panel] Backup function doesn't work

Postby dsi-lille » Wed May 24, 2017 7:37 am

Hello Maxim,

i can't, i get a timeout.
And i'm not surprise, this table contains 7 101 113 rows.
The most older event was recorded the 30/06/2016.

Thanks,
Yoann
dsi-lille
 
Posts: 88
Joined: Mon Jul 11, 2016 1:47 pm

Re: [Control Panel] Backup function doesn't work

Postby Maxim » Wed May 24, 2017 3:17 pm

Hello Yoann!
Specify please is there a difference between timezone of the portal (in the portal settings) and timezone in the Community Server container?
Maxim
 
Posts: 663
Joined: Tue Oct 11, 2016 2:34 pm


Return to Enterprise Version

Who is online

Users browsing this forum: No registered users and 1 guest