Try the fastest and simplest way to install ONLYOFFICE

Can't Open in edit mode

Any issues about docs (uploading, editing and etc.)

Can't Open in edit mode

Postby kevinb » Mon Nov 21, 2016 6:12 pm

Hey all, I'm having an issue that's driving me crazy. First, I downloaded the vmware image of OnlyOffice to load on my test server. Everything started up and ran fine. I logged in and opened each of the sample documents included and they all worked fine. Any changes were saved, etc. So I figured this would be a good system for a user of mine that wants to be able to have a few people be able to open shared documents and edit them. I then figured I'll install it on a vps for them. I followed the Linux instructions to install on Centos 7 x64. Everything succeeded clean, no errors. Started up the system and logged into the portal. The 3 demo files are there, however there is no longer an option to edit them. I went into the settings area for integration->document service and compared the entries in there to what I have on the new server (all empty). I tried adding the url's per the examples listed on that page, but no matter what I put in there it will not even save. All I get is an error stating "Api url: Service is not defined". I have tried both custom and non-custom DNS entries for the portal name and nothing works. I also tried the settings I have in the vmware system, but they don't work either (I didn't think they would but figured I'd try anyway). Can anyone shed some light on this? Any services to check? I just cant get it to save/work, even if I DO set the dns name in the URL to the custom DNS name I set in the customization area. Without being able to edit the files kind of defeats the purpose of everything. Don't know if I'm missing something obvious here or what, but I've tried everything and can't get any of the URL's in the document service location area to save without that error, so nothing works. Thanks.

Kevin
kevinb
 
Posts: 3
Joined: Mon Nov 21, 2016 6:00 pm

Re: Can't Open in edit mode

Postby Maxim » Tue Nov 22, 2016 7:29 am

Hello Kevin!
As i see vmware image you used worked fine. That image includes Document Server and Community server that's why you were able to work with docs. But later you tried to install OnlyOffice - please specify what kind of OnlyOffice installation you used for each server (for Document and Community servers) - docker or Linux version.
Community Server Docker installation
Document Server Docker installation
Community Server linux installation
Document Server linux instalation
We advice you to install on your VPS Docker Version of OnlyOffice Enterprise Edition using the provided script. It's very easy way to begin using OnlyOffice.
Maxim
 
Posts: 379
Joined: Tue Oct 11, 2016 2:34 pm


Return to Documents

Who is online

Users browsing this forum: Google [Bot] and 4 guests