Page 1 of 1

Issues with WORKDAY function

PostPosted: Tue Oct 10, 2017 10:21 pm
by RKD-IT
This seems like an issue when you use a one day offset. Wen we use a 1 day offset, it uses the weekend days. If you use a 2 day-offset, it will skip the 2 weekend days and count the next 2 workdays.

I am trying to attach a sample xlsx that it creates by default but it is not allowing xlsx attachments. When I convert it to an ods in Excel, it fixes the incorrect line

Basically In A11 I have a date 10/9/2017

In B3 I have a date 10/2/2017
In C3 I have =WORKDAY(B3,1,$A$11) <- this cell = 10/3/2017
In D3 I have =WORKDAY(C3,1,$A$11) <- this cell = 10/4/2017
In E3 I have =WORKDAY(D3,1,$A$11) <- this cell = 10/5/2017
In F3 I have =WORKDAY(E3,1,$A$11) <- this cell = 10/6/2017
In G3 I have =WORKDAY(F3,1,$A$11) <- this cell = 10/7/2017
In H3 I have =WORKDAY(G3,1,$A$11) <- this cell = 10/8/2017
In I3 I have =WORKDAY(H3,1,$A$11) <- this cell = 10/9/2017

The above cell values should not count the 10/7 & 10/8 which are weekend days. They should not count 10/9 either since it was the specified holiday

Below is what is expected. This is what appears if you attempt to open this in Excel and Enable Editing. When you enable editing it immediately fixed the values to what is expected as shown below:

Basically In A11 I have a date 10/9/2017

In B3 I have a date 10/2/2017
In C3 I have =WORKDAY(B3,1,$A$11) <- this cell = 10/3/2017
In D3 I have =WORKDAY(C3,1,$A$11) <- this cell = 10/4/2017
In E3 I have =WORKDAY(D3,1,$A$11) <- this cell = 10/5/2017
In F3 I have =WORKDAY(E3,1,$A$11) <- this cell = 10/6/2017
In G3 I have =WORKDAY(F3,1,$A$11) <- this cell = 10/10/2017
In H3 I have =WORKDAY(G3,1,$A$11) <- this cell = 10/11/2017
In I3 I have =WORKDAY(H3,1,$A$11) <- this cell = 10/12/2017

What do you think?

Re: Issues with WORKDAY function

PostPosted: Thu Oct 12, 2017 1:41 pm
by RKD-IT
Out of all the views so far, can anyone replicate this issue?

Re: Issues with WORKDAY function

PostPosted: Fri Oct 13, 2017 9:50 am
by Maxim
Hello RKD-IT!
Thank you for provided information!
We have detected the bug!
We will try to fix as soon as possible.