Try the fastest and simplest way to install ONLYOFFICE

ONLYOFFICE sends links with "http" and not "https"

IIS, Apache

ONLYOFFICE sends links with "http" and not "https"

Postby paravis » Sun May 31, 2015 3:40 pm

Hello,

I have been playing/testing ONLYOFFICE now for only a day or so, and I am stumped on how to get notifications or emails containing a link to the page to show "https://" instead of "http://".

Nginx is configured to use only SSL (no HTTP port 80 open), and all client connections are coming into port 443 with SSL.

Is there a configuration directive somewhere to enforce HTTPS?

Thanks!
~Laz
paravis
 
Posts: 6
Joined: Sun May 31, 2015 3:07 pm

Re: ONLYOFFICE sends links with "http" and not "https"

Postby paravis » Mon Jun 01, 2015 1:34 pm

Please reference http://dev.onlyoffice.org/viewtopic.php?f=10&t=6157#p7803 for more information. Seems to be related.

With DNS custom domain name enabled, ONLYOFFICE does not properly build the activation link. It always uses http (instead of https in my case) with the custom domain name.

Removing the custom domain name option sends the email with activation link to whatever domain name or IP that I have typed in the address bar. So, in this case, it will have the https if that is what I am accessing.
paravis
 
Posts: 6
Joined: Sun May 31, 2015 3:07 pm

Re: ONLYOFFICE sends links with "http" and not "https"

Postby Dean » Tue Jun 23, 2015 12:33 pm

We can suggest you to transfer all the requests from the 80 to 443 manually.

Also to enable HTTPS please, read the documentation here here
Dean
 
Posts: 700
Joined: Tue Sep 30, 2014 11:04 am


Return to Web server configuration

Who is online

Users browsing this forum: Bing [Bot] and 1 guest