Try the fastest and simplest way to install ONLYOFFICE

Bad URL for notification confirm for new user

Adding a first (new) user / portal activity notifications / email / chat

Bad URL for notification confirm for new user

Postby Kpol » Mon Feb 09, 2015 3:28 pm

Hello,

Now i use for my server a SSL, but email notification confirm for new user still send in http ... ?
In Settings>Dns setting>Custom DNS>... I enter
Code: Select all
https://mydomaine.org

but after "Save" i have only
Code: Select all
http://mydomaine.org

inside.... :|
User avatar
Kpol
 
Posts: 97
Joined: Fri Feb 06, 2015 5:58 am
Location: Bangkok, Thailand.

Re: Bad URL for notification confirm for new user

Postby Dean » Thu Feb 19, 2015 8:47 am

What exactky appears after following the link from the notification? Is the address on the http:// or on the https://?
Dean
 
Posts: 700
Joined: Tue Sep 30, 2014 11:04 am

Re: Bad URL for notification confirm for new user

Postby Kpol » Thu Feb 19, 2015 9:15 am

Update : Sorry! In fact pb doesn't solved ....

Code: Select all
What exactky appears after following the link from the notification? Is the address on the http:// or on the https://?


I use https://
User avatar
Kpol
 
Posts: 97
Joined: Fri Feb 06, 2015 5:58 am
Location: Bangkok, Thailand.

Re: Bad URL for notification confirm for new user

Postby cksoft » Sat Mar 25, 2017 2:57 pm

Hello all,

Same problem for me the confirmation link is http:// not https://
Where can i change that ?
Thanks

(I'm using Community server lastest / Docker / Linux ubuntu )
cksoft
 
Posts: 5
Joined: Sat Mar 25, 2017 2:54 pm

Re: Bad URL for notification confirm for new user

Postby Maxim » Mon Mar 27, 2017 6:45 am

Hello cksoft!
Specify please your OnlyOffice server works with SSL? Did you configure Community Server to work with SSL?
Running Community Server using HTTPS protocol
Maxim
 
Posts: 1162
Joined: Tue Oct 11, 2016 2:34 pm

Re: Bad URL for notification confirm for new user

Postby cksoft » Mon Mar 27, 2017 7:22 am

Yes under apache VHOST / Proxy -> Docker container / port 20443

Code: Select all
 
...
ProxyRequests off
        <Location />
                ProxyPass https://127.0.0.1:20443/
                ProxyPassReverse /
        </Location>
      <IfModule mod_headers.c>
        Header always set Strict-Transport-Security "max-age=15768000; includeSubDomains; preload"
      </IfModule>
...


Ubuntu 16.04.x SSLABS A+

In general settings / Documents settings

Community Server Address
https://office.mydomain.xxx <- my settings
Exemple: http://office.mydomain.xxx (the exemple)

In general settings / Customise
DNS SETTING
office.mydomain.xxx

The DocumentServer works fine.

Thanks
cksoft
 
Posts: 5
Joined: Sat Mar 25, 2017 2:54 pm

Re: Bad URL for notification confirm for new user

Postby Maxim » Mon Mar 27, 2017 9:43 am

OnlyOffice (Community and Document servers) server works with HTTPS correctly. You have put your certs into /app/onlyoffice/CommunityServer/data/certs/ but the link in email notification still with no https?
Maxim
 
Posts: 1162
Joined: Tue Oct 11, 2016 2:34 pm

Re: Bad URL for notification confirm for new user

Postby cksoft » Mon Mar 27, 2017 9:53 am

Maxim wrote:OnlyOffice (Community and Document servers) server works with HTTPS correctly. You have put your certs into /app/onlyoffice/CommunityServer/data/certs/ but the link in email notification still with no https?


that's exactly what i did :) (volume created with docker container)
Code: Select all
sudo docker run --net onlyoffice -i -t -d --restart=always --name onlyoffice-community-server \
   -p 20443:443 \
    -v /app/onlyoffice/CommunityServer/data:/var/www/onlyoffice/Data \
    -v /app/onlyoffice/CommunityServer/mysql:/var/lib/mysql \
    -v /app/onlyoffice/CommunityServer/logs:/var/log/onlyoffice \
    -v /app/onlyoffice/DocumentServer/data:/var/www/onlyoffice/DocumentServerData \
    -e DOCUMENT_SERVER_PORT_5443_TCP_ADDR=onlyoffice-document-server \
       onlyoffice/communityserver


After i've created a self signed cert and put it in the good folder ...
/app/onlyoffice/CommunityServer/data/certs

the files are :
dhparam.pem
onlyoffice.crt
onlyoffice.csr
onlyoffice.key

Everything works fine but i don't understand about this link (chat, crm, etc....)
Ok i can try to solve that with Rewrite Rule but i prefer to correct this issue :)
May be there is a specific file to modify ?
cksoft
 
Posts: 5
Joined: Sat Mar 25, 2017 2:54 pm

Re: Bad URL for notification confirm for new user

Postby Maxim » Mon Mar 27, 2017 11:29 am

Please attach screenshot of the mail with URL for notification if it's possible.
Maxim
 
Posts: 1162
Joined: Tue Oct 11, 2016 2:34 pm

Re: Bad URL for notification confirm for new user

Postby cksoft » Mon Mar 27, 2017 11:55 am

Maxim wrote:Please attach screenshot of the mail if it's possible.


There it is
Image
cksoft
 
Posts: 5
Joined: Sat Mar 25, 2017 2:54 pm

Next

Return to Notification issues

Who is online

Users browsing this forum: No registered users and 1 guest