Try the fastest and simplest way to install ONLYOFFICE

Bad URL for notification confirm for new user

Adding a first (new) user / portal activity notifications / email / chat

Re: Bad URL for notification confirm for new user

Postby Maxim » Mon Mar 27, 2017 1:15 pm

Please try to reboot OO server and at the beginning enter to the portal with https and than try to create user and check mail notification again.
Maxim
 
Posts: 1001
Joined: Tue Oct 11, 2016 2:34 pm

Re: Bad URL for notification confirm for new user

Postby cksoft » Mon Mar 27, 2017 8:06 pm

I've restarted the container (sudo docker restart XXXX) and no change
same with docker service (sudo service docker restart) idem

Finaly i've created VHOST:80,

Code: Select all
<VirtualHost *:80>
   ServerName office.mydomaine.com
   DocumentRoot /usr/local/apache2/htdocs
   Redirect permanent / https://office.mydomaine.com
    <location />
        Order deny,allow
        Allow from all
        AllowOverride none
        Require all granted
    </location>
</VirtualHost>


And it's ok for redirect 80 -> 443 -> proxyreverse Apache -> 20443 (docker container is 20443:443)

But always the same issue with email URL (http://)

i've looked in email source code (because there is a issue with images inside) so :
Code: Select all
<a href=3D"http://www.onlyoffice.com/" style=3D"text-d=
ecoration: none; display: inline-block; width: 216px; height: 35px; ma=
rgin: 0; padding: 0;" target=3D"_blank">
                    <img src=3D"http://office.mydomain.com/skins/default/=
images/onlyoffice_logo/dark_general.png" style=3D"border: 0px none; wi=
dth: 216px; height: 35px; margin: 0; padding: 0;" alt=3D"ONLYOFFICE" /=
>


As you can see address is http:// for the elements and there is a strange "=3D" like %3D ??? so there is no image either...

Apart from these few details, everything works fine.
Very nice product.

thanks
cksoft
 
Posts: 5
Joined: Sat Mar 25, 2017 2:54 pm

Re: Bad URL for notification confirm for new user

Postby Maxim » Wed Mar 29, 2017 8:58 am

Hello cksoft!
Tried to reproduce the issue but have no luck!
Maxim
 
Posts: 1001
Joined: Tue Oct 11, 2016 2:34 pm

Previous

Return to Notification issues

Who is online

Users browsing this forum: No registered users and 1 guest