Try the fastest and simplest way to install ONLYOFFICE

setting the correct path for backup

Update/Migration/Backup issues

setting the correct path for backup

Postby alireza » Thu Jan 08, 2015 8:43 pm

Hi,
I want to create a backup of our portal, but if I click the "Perform Backup" button in the Settings page, I get the error "The given path's format is not supported."
Where can I set this path?

Best,
Ali
alireza
 
Posts: 6
Joined: Sat Aug 30, 2014 6:08 am

Re: setting the correct path for backup

Postby Eugenie » Fri Jan 09, 2015 2:23 pm

Please specify the version you use, your OS, describe your actions step by step, send us a screenshot of console at the moment when the issue appears.
Eugenie
 
Posts: 134
Joined: Mon Aug 25, 2014 10:11 am

Re: setting the correct path for backup

Postby alireza » Fri Jan 09, 2015 3:45 pm

Hi,
We're using OnlyOffice 7.7 on IIS , Win 7 (professional edition) and this is the screenshot and the steps that I take. According to the help page, a link for a zip file should become available instead of this error message.

Best,
Ali

Image
alireza
 
Posts: 6
Joined: Sat Aug 30, 2014 6:08 am

Re: setting the correct path for backup

Postby AnaMih » Thu Jan 15, 2015 10:46 am

Please, provide us the file you may find here: c:\Program Files\Ascensio System SIA\ONLYOFFICE\Backup\TeamLabSvc.exe.Config via email support@onlyoffice.com and please insert the link to this thread into your email.
User avatar
AnaMih
 
Posts: 264
Joined: Mon Aug 25, 2014 10:15 am

Re: setting the correct path for backup

Postby alireza » Thu Jan 15, 2015 9:01 pm

Hi AnaMih,
I checked the latest log file in c:\Program Files (x86)\Ascensio System SIA\ONLYOFFICE\logs\backup :

Code: Select all
2015-01-15 04:08:45,050 ERROR [127] ASC.Backup - System.IO.DirectoryNotFoundException: Directory 'C:\Program Files (x86)\Ascensio System SIA\ONLYOFFICE\WebStudio\data\backupfiles\backup\' not found
   at ASC.Data.Storage.DiscStorage.DiscDataStore.DeleteExpired(String domain, String folderPath, TimeSpan oldThreshold)
   at ASC.Data.Backup.Service.BackupService.Clean(Object period)


I created this folder manually and tried the same process again, now I get this error:
Code: Select all
Could not connect to net.tcp://localhost:9882/teamlabBackup. The connection attempt lasted for a time span of 00:00:02.0070000. TCP error code 10061: No connection could be made because the target machine actively refused it 127.0.0.1:9882.


I turned off the firewall and antivirus but the problem still persists.
Do you still need to review the config file?

Best,
Ali
alireza
 
Posts: 6
Joined: Sat Aug 30, 2014 6:08 am

Re: setting the correct path for backup

Postby AnaMih » Tue Jan 20, 2015 8:05 am

Yes. it would be better to see all log-files and *.config file.
User avatar
AnaMih
 
Posts: 264
Joined: Mon Aug 25, 2014 10:15 am

Re: setting the correct path for backup

Postby AnaMih » Wed Jan 21, 2015 3:35 pm

To solve the issue, please check if all 11 ONLYOFFICE services are started, ONLYOFFICE Backup also. If ONLYOFFICE Backup service is started, please restart it, clear the browser cache, renew the page and try to create Backup once again.
User avatar
AnaMih
 
Posts: 264
Joined: Mon Aug 25, 2014 10:15 am

Re: setting the correct path for backup

Postby alireza » Fri Jan 23, 2015 7:54 pm

Hello AnaMih,
I made sure that all 11 services are running, I restarted the BackUp service, cleared the cache and tried different browsers. I still get the error "The given path's format is not supported."
The screenshot of this error is on this page and this is the newest entry in BackUp Log:
Code: Select all
2015-01-22 09:36:58,660 ERROR [queue_worker_1] ASC.Backup - System.NotSupportedException: The given path's format is not supported.
   at System.Security.Util.StringExpressionSet.CanonicalizePath(String path, Boolean needFullPath)
   at System.Security.Util.StringExpressionSet.CreateListFromExpressions(String[] str, Boolean needFullPath)
   at System.Security.Permissions.FileIOPermission.AddPathList(FileIOPermissionAccess access, AccessControlActions control, String[] pathListOrig, Boolean checkForDuplicates, Boolean needFullPath, Boolean copyPathList)
   at System.Security.Permissions.FileIOPermission.AddPathList(FileIOPermissionAccess access, String[] pathListOrig, Boolean checkForDuplicates, Boolean needFullPath, Boolean copyPathList)
   at System.Security.Permissions.FileIOPermission..ctor(FileIOPermissionAccess access, String[] pathList, Boolean checkForDuplicates, Boolean needFullPath)
   at System.IO.File.InternalDelete(String path, Boolean checkHost)
   at ASC.Data.Backup.Service.ProgressItems.BackupProgressItem.RunInternal()
   at ASC.Data.Backup.Service.ProgressItems.BackupProgressItemBase.RunJob()


How can I set this path correctly?

Best,
Ali
alireza
 
Posts: 6
Joined: Sat Aug 30, 2014 6:08 am

Re: setting the correct path for backup

Postby AnaMih » Fri Jan 30, 2015 3:20 pm

We need the configuration file in order to analyse the problem with the paths.
Installation folders are \Data\Backup и \WebStudio\Data\Backup and backup settings specified in the *.config files.
User avatar
AnaMih
 
Posts: 264
Joined: Mon Aug 25, 2014 10:15 am

Re: setting the correct path for backup

Postby alireza » Tue Feb 03, 2015 4:12 pm

Hello AnaMih,
Thank you for the reply.
These two folders are empty: \Data\Backup и \WebStudio\Data\Backup
and I find backup settings in these config files. I am not sure which is the one to be changed:

C:\Program Files (x86)\Ascensio System SIA\ONLYOFFICE\Backup\TeamLabSvc.exe.Config
Code: Select all
...
...
 <teamlab>
    <services>
      <add type="ASC.Data.Backup.Service.BackupServiceLauncher, ASC.Data.Backup" />
    </services>
  </teamlab>
...
...
  <backup>
    <webConfigs current="local">
      <add region="local" path="..\WebStudio\" />
    </webConfigs>
  </backup>
...
...
<service name="ASC.Data.Backup.Service.BackupService">
        <endpoint address="net.tcp://0.0.0.0:9882/teamlabBackup" binding="netTcpBinding" contract="ASC.Core.Common.Contracts.IBackupService" bindingConfiguration="backup" />
      </service>
...
...
        <binding name="backup" openTimeout="0:0:10" receiveTimeout="0:0:10" sendTimeout="0:0:10">
          <security mode="None" />
          <readerQuotas maxStringContentLength="1000000" />
        </binding>
...


C:\Program Files (x86)\Ascensio System SIA\ONLYOFFICE\WebStudio\web.storage.config
Code: Select all
<add name="backup" type="disc" path="..\WebStudio\data\{0}\backup" virtualpath="~/data/{0}/backup" visible="false" />


C:\Program Files (x86)\Ascensio System SIA\ONLYOFFICE\WebStudio\Web.config
Code: Select all
 <client>
      <endpoint address="net.tcp://localhost:9865/teamlabJabber" binding="netTcpBinding" contract="ASC.Core.Notify.Jabber.IJabberService" bindingConfiguration="jabber" />
      <endpoint address="net.tcp://localhost:9866/teamlabSearcher" binding="netTcpBinding" contract="ASC.FullTextIndex.ITextIndexService" bindingConfiguration="index" />
      <endpoint address="net.tcp://localhost:9871/teamlabNotify" binding="netTcpBinding" contract="ASC.Notify.INotifyService" bindingConfiguration="notify" />
      <endpoint contract="ASC.Core.Common.Contracts.IBackupService" address="net.tcp://localhost:9882/teamlabBackup" binding="netTcpBinding" bindingConfiguration="backup" />
    </client>


I've previously emailed you the web.config file but if you need it again or the other config files, let me know and I will email you the files again.

Best,
Ali
alireza
 
Posts: 6
Joined: Sat Aug 30, 2014 6:08 am

Next

Return to Upgrade

Who is online

Users browsing this forum: No registered users and 3 guests

cron