Попробуйте самый простой и быстрый способ 
установки OnlyOffice

Не работает запрос к batch.json

Установка и первый запуск

Не работает запрос к batch.json

Сообщение Fuzzy-Wuzzy » Ср май 18, 2016 4:13 pm

Возникла проблема при доступе к функциям Сервера совместной работы для Windows. Сервер был скомпилирован из исходников в соответствии с инструкцией (http://helpcenter.onlyoffice.com/ru/ser ... -code.aspx) и развёрнут на платформе Windows 2012 Server/IIS 8. Компиляция прошла без ошибок, Windows - сервисы запускаются, установил и подтвердил пароль администратора, настроил реквизиты SMTP - сервера. После этого выхожу из системы, заново авторизуюсь и наблюдаю следующую картину:

1. В консоли Chrome выдаётся сообщение POST http://<my_server_ipaddress>/api/2.0/batch.json?__=594196 404 (Not Found)
2. При попытке открыть список людей отображается индикатор загрузки, в консоли те же сообщения относительно batch.json not found. То же самое при обращении к любым другим спискам (проектов и т.д.)
3. На сервере в логе web.api.log наблюдаются сообщения:

ERROR [6] ASC.Api.ApiSetupHttpModule - System.InvalidOperationException: The type name or alias ASC.Api.Security.SecurityApi could not be resolved. Please check your configuration file and verify this type name.
at Microsoft.Practices.Unity.Configuration.ConfigurationHelpers.TypeResolverImpl.ResolveType(String typeNameOrAlias, Boolean throwIfResolveFails)
at Microsoft.Practices.Unity.Configuration.RegisterElement.ConfigureContainer(IUnityContainer container)
at Microsoft.Practices.Unity.Configuration.ContainerElement.<>c__DisplayClass1.<ConfigureContainer>b__0(ContainerConfiguringElement element)
at Microsoft.Practices.ObjectBuilder2.EnumerableExtensions.ForEach[TItem](IEnumerable`1 sequence, Action`1 action)
at Microsoft.Practices.Unity.Configuration.UnityContainerExtensions.LoadConfiguration(IUnityContainer container, UnityConfigurationSection section, String containerName)
at ASC.Api.ApiSetup.Init()
at ASC.Api.ApiSetup.ConfigureEntryPoints()
at ASC.Api.ApiSetupHttpModule.Init(HttpApplication context)

Вопрос: кто виноват и что делать?

Заранее благодарен за подсказку направления куда копать.
Fuzzy-Wuzzy
 
Сообщения: 2
Зарегистрирован: Ср май 18, 2016 3:56 pm

Re: Не работает запрос к batch.json

Сообщение Fuzzy-Wuzzy » Пн май 23, 2016 8:35 am

Представители компании - разработчика, скажите хоть что-нибудь. Прокомментируйте ситуацию.
Fuzzy-Wuzzy
 
Сообщения: 2
Зарегистрирован: Ср май 18, 2016 3:56 pm

Re: Не работает запрос к batch.json

Сообщение Dean » Пн май 30, 2016 7:55 am

Здравствуйте,

Приноршу извинения за задержку. Проблема у нас воспроизводится, однако ее решение займет некоторое время.
Dean
 
Сообщения: 461
Зарегистрирован: Вт сен 30, 2014 11:04 am


Вернуться в Проблемы при установке на Win OS

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 1