Попробуйте самый простой и быстрый способ 
установки OnlyOffice

DocumentServer, Ubuntu 16.04 Ошибка установки Node.js

Проблемы, связанные с процессом установки

DocumentServer, Ubuntu 16.04 Ошибка установки Node.js

Сообщение Stas43 » Пн апр 09, 2018 1:12 pm

Добрый день!

Установка на чистый сервер Ubuntu 16.04 LTS x64
Инструкция для установки: https://helpcenter.onlyoffice.com/server/linux/document/linux-installation.aspx
Первая же инструкция curl -sL https://deb.nodesource.com/setup_6.x | sudo bash - вызвала ошибку: (кстати, её выполнять от root`a или простого пользователя?)

Вывод терминала
sm@docserver:~$ sudo curl -sL https://deb.nodesource.com/setup_6.x | sudo bash -[sudo] пароль для sm:

## Installing the NodeSource Node.js v6.x LTS Boron repo...


## Populating apt-get cache...

+ apt-get update
Пол:1 http://security.ubuntu.com/ubuntu xenial-security InRelease [102 kB]
Сущ:2 http://ru.archive.ubuntu.com/ubuntu xenial InRelease
Пол:3 http://ru.archive.ubuntu.com/ubuntu xenial-updates InRelease [102 kB]
Пол:4 http://ru.archive.ubuntu.com/ubuntu xenial-backports InRelease [102 kB]
Получено 306 kБ за 1с (242 kБ/c)
Чтение списков пакетов… Готово

## Installing packages required for setup: apt-transport-https...

+ apt-get install -y apt-transport-https > /dev/null 2>&1

## Confirming "xenial" is supported...

+ curl -sLf -o /dev/null 'https://deb.nodesource.com/node_6.x/dists/xenial/Release'

## Adding the NodeSource signing key to your keyring...

+ curl -s https://deb.nodesource.com/gpgkey/nodesource.gpg.key | apt-key add -
OK

## Creating apt sources list file for the NodeSource Node.js v6.x LTS Boron repo...

+ echo 'deb https://deb.nodesource.com/node_6.x xenial main' > /etc/apt/sources.list.d/nodesource.list
+ echo 'deb-src https://deb.nodesource.com/node_6.x xenial main' >> /etc/apt/sources.list.d/nodesource.list

## Running `apt-get update` for you...

+ apt-get update
Игн:1 https://deb.nodesource.com/node_6.x xenial InRelease
Игн:2 https://deb.nodesource.com/node_6.x xenial Release
Игн:3 https://deb.nodesource.com/node_6.x xenial/main Sources
Игн:4 https://deb.nodesource.com/node_6.x xenial/main amd64 Packages
Игн:5 https://deb.nodesource.com/node_6.x xenial/main i386 Packages
Игн:6 https://deb.nodesource.com/node_6.x xenial/main all Packages
Игн:7 https://deb.nodesource.com/node_6.x xenial/main Translation-ru_RU
Игн:8 https://deb.nodesource.com/node_6.x xenial/main Translation-ru
Игн:9 https://deb.nodesource.com/node_6.x xenial/main Translation-en
Игн:3 https://deb.nodesource.com/node_6.x xenial/main Sources
Игн:4 https://deb.nodesource.com/node_6.x xenial/main amd64 Packages
Игн:5 https://deb.nodesource.com/node_6.x xenial/main i386 Packages
Игн:6 https://deb.nodesource.com/node_6.x xenial/main all Packages
Игн:7 https://deb.nodesource.com/node_6.x xenial/main Translation-ru_RU
Игн:8 https://deb.nodesource.com/node_6.x xenial/main Translation-ru
Игн:9 https://deb.nodesource.com/node_6.x xenial/main Translation-en
Игн:3 https://deb.nodesource.com/node_6.x xenial/main Sources
Игн:4 https://deb.nodesource.com/node_6.x xenial/main amd64 Packages
Игн:5 https://deb.nodesource.com/node_6.x xenial/main i386 Packages
Игн:6 https://deb.nodesource.com/node_6.x xenial/main all Packages
Игн:7 https://deb.nodesource.com/node_6.x xenial/main Translation-ru_RU
Игн:8 https://deb.nodesource.com/node_6.x xenial/main Translation-ru
Игн:9 https://deb.nodesource.com/node_6.x xenial/main Translation-en
Игн:3 https://deb.nodesource.com/node_6.x xenial/main Sources
Игн:4 https://deb.nodesource.com/node_6.x xenial/main amd64 Packages
Игн:5 https://deb.nodesource.com/node_6.x xenial/main i386 Packages
Игн:6 https://deb.nodesource.com/node_6.x xenial/main all Packages
Игн:7 https://deb.nodesource.com/node_6.x xenial/main Translation-ru_RU
Игн:8 https://deb.nodesource.com/node_6.x xenial/main Translation-ru
Игн:9 https://deb.nodesource.com/node_6.x xenial/main Translation-en
Игн:3 https://deb.nodesource.com/node_6.x xenial/main Sources
Игн:4 https://deb.nodesource.com/node_6.x xenial/main amd64 Packages
Игн:5 https://deb.nodesource.com/node_6.x xenial/main i386 Packages
Игн:6 https://deb.nodesource.com/node_6.x xenial/main all Packages
Игн:7 https://deb.nodesource.com/node_6.x xenial/main Translation-ru_RU
Игн:8 https://deb.nodesource.com/node_6.x xenial/main Translation-ru
Игн:9 https://deb.nodesource.com/node_6.x xenial/main Translation-en
Ошк:3 https://deb.nodesource.com/node_6.x xenial/main Sources
Received HTTP code 403 from proxy after CONNECT
Игн:4 https://deb.nodesource.com/node_6.x xenial/main amd64 Packages
Игн:5 https://deb.nodesource.com/node_6.x xenial/main i386 Packages
Игн:6 https://deb.nodesource.com/node_6.x xenial/main all Packages
Игн:7 https://deb.nodesource.com/node_6.x xenial/main Translation-ru_RU
Игн:8 https://deb.nodesource.com/node_6.x xenial/main Translation-ru
Игн:9 https://deb.nodesource.com/node_6.x xenial/main Translation-en
Сущ:10 http://security.ubuntu.com/ubuntu xenial-security InRelease
Сущ:11 http://ru.archive.ubuntu.com/ubuntu xenial InRelease
Сущ:12 http://ru.archive.ubuntu.com/ubuntu xenial-updates InRelease
Сущ:13 http://ru.archive.ubuntu.com/ubuntu xenial-backports InRelease
Чтение списков пакетов… Готово
W: Репозиторий «https://deb.nodesource.com/node_6.x xenial Release» не содержит файла Release.
N: Данные из этого репозитория нельзя аутентифицировать, и поэтому потенциально из небезопасно использовать.
N: Смотрите справочную страницу apt-secure(8) о создании репозитория и настройке пользователя.
E: Не удалось получить https://deb.nodesource.com/node_6.x/dis ... ce/Sources Received HTTP code 403 from proxy after CONNECT
E: Некоторые индексные файлы не скачались. Они были проигнорированы или вместо них были использованы старые версии.
Error executing command, exiting


Это, кстати, вторая попытка. В 1 попытке ставил через NVM. по этой https://community.vscale.io/hc/ru/community/posts/209000165-%D0%9A%D0%B0%D0%BA-%D1%83%D1%81%D1%82%D0%B0%D0%BD%D0%BE%D0%B2%D0%B8%D1%82%D1%8C-Node-js-%D0%BD%D0%B0-%D1%81%D0%B5%D1%80%D0%B2%D0%B5%D1%80-%D1%81-Ubuntu-16-04ссылке. Результат аналогичный:((
Stas43
 
Сообщения: 3
Зарегистрирован: Пн апр 09, 2018 12:56 pm

Re: DocumentServer, Ubuntu 16.04 Ошибка установки Node.js

Сообщение Stas43 » Ср апр 18, 2018 6:17 am

Решил, было, попробовать установить этот продукт в организации. Но, видимо, не судьба... Разработчикам пофигу вопросы пользователей. Если вы хотите, чтобы я сначала купил, а потом спрашивал - ничего подобного! Я сначала ставлю-пробую-спрашиваю, вы решаете проблемы, и если все ок, то я решаю вопрос с покупкой.
Stas43
 
Сообщения: 3
Зарегистрирован: Пн апр 09, 2018 12:56 pm

Re: DocumentServer, Ubuntu 16.04 Ошибка установки Node.js

Сообщение Kirill_sol » Пт май 04, 2018 7:39 am

Здравствуйте.

Приносим извинения за столь поздний ответ.

Данная ошибка указывает на некорректно настроенный прокси. Попробуйте исправить эти настройки.
Kirill_sol
 
Сообщения: 167
Зарегистрирован: Чт апр 12, 2018 9:58 am

Re: DocumentServer, Ubuntu 16.04 Ошибка установки Node.js

Сообщение Stas43 » Пт май 04, 2018 11:35 am

Kirill_sol писал(а):Здравствуйте.

Приносим извинения за столь поздний ответ.

Данная ошибка указывает на некорректно настроенный прокси. Попробуйте исправить эти настройки.


Какие конкретно и годе? У меня вообще прокси нигде не используется.
Stas43
 
Сообщения: 3
Зарегистрирован: Пн апр 09, 2018 12:56 pm

Re: DocumentServer, Ubuntu 16.04 Ошибка установки Node.js

Сообщение Alex » Пт май 11, 2018 8:34 am

Здравствуйте.
Нам очень жаль, что Вы столкнулись с проблемами при установке nodejs
Как только nodejs будет установлен на сервер (вместе со всеми остальными зависимостями, указанными в инструкции), можно перехордить к установке и настройке продукта ONLYOFFICE
Вы также можете попробовать установку docker версии продукта, которая не потребует от Вас никаких дополнительных манипуляций кроме установки самого докера (что тоже делается скриптом)
Alex
 
Сообщения: 136
Зарегистрирован: Сб ноя 07, 2015 3:26 pm


Вернуться в Проблемы при установке

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 1