Попробуйте самый простой и быстрый способ 
установки OnlyOffice

Не работает чат через веб-клиент ver7.7.1

Добавление первого (нового) пользователя / оповещения с портала / ПОЧТА / ЧАТ

Не работает чат через веб-клиент ver7.7.1

Сообщение ArLex » Чт мар 26, 2015 5:29 am

OnlyOffice 7.7.1 установлен на Windows 2012 R2 x64.

Вебклиент для чата не хочет работать. При запуске /addons/talk/jabberclient.aspx идет вечное соединение...
Через QIP все настроилось нормально.

Уже все конфиги перепроверил не по разу. Открыл порты на брандмауэре: 80, 443, 8086, 5222, 5280, 9865, 9866, 9871, 8885

Были у кого подобные проблемы ?
ArLex
 
Сообщения: 18
Зарегистрирован: Пн мар 23, 2015 7:23 pm

Re: Не работает чат через веб-клиент

Сообщение AnaMih » Чт мар 26, 2015 12:35 pm

Подобной ошибки у нас, к сожалению, не проявлялось. Проанализируйте, пожалуйста, сетевой трафик в браузере.
Проверьте нет ли ошибок в логах чата c:\Program Files\Ascensio System SIA\ONLYOFFICE\Logs\Jabber\, а также в логах портала c:\Program Files\Ascensio System SIA\ONLYOFFICE\Logs\TeamLab.Web.-дата-.log. Или Вы можете прислать логи нам для анализа по адресу support@onlyoffice.com с указанием данного треда.
Аватара пользователя
AnaMih
 
Сообщения: 630
Зарегистрирован: Пн авг 25, 2014 10:15 am

Re: Не работает чат через веб-клиент

Сообщение ArLex » Пт мар 27, 2015 6:36 am

Ошибки в логах Jabber'a:

Код: Выделить всё
2015-03-23 17:20:30,429 ERROR [171] ASC.Xmpp.Server.ReverseJabberServiceClient - Service Error: Тип содержимого text/plain ответного сообщения не соответствует типу содержимого привязки (text/xml; charset=utf-8). При использовании особого кодировщика необходимо правильно реализовать метод IsContentTypeSupported. Первые 89 байтов ответного сообщения: "An error has occurred: {"code":"ECONNREFUSED","errno":"ECONNREFUSED","syscall":"connect"}".,
Server stack trace:
   в System.ServiceModel.Channels.HttpChannelUtilities.ValidateRequestReplyResponse(HttpWebRequest request, HttpWebResponse response, HttpChannelFactory`1 factory, WebException responseException, ChannelBinding channelBinding)
   в System.ServiceModel.Channels.HttpChannelFactory`1.HttpRequestChannel.HttpChannelRequest.WaitForReply(TimeSpan timeout)
   в System.ServiceModel.Channels.RequestChannel.Request(Message message, TimeSpan timeout)
   в System.ServiceModel.Dispatcher.RequestChannelBinder.Send(Message message, TimeSpan timeout)
   в System.ServiceModel.Channels.ServiceChannel.Call(String action, Boolean oneway, ProxyOperationRuntime operation, Object[] ins, Object[] outs, TimeSpan timeout)
   в System.ServiceModel.Channels.ServiceChannelProxy.InvokeService(IMethodCallMessage methodCall, ProxyOperationRuntime operation)
   в System.ServiceModel.Channels.ServiceChannelProxy.Invoke(IMessage message)

Exception rethrown at [0]:
   в System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg)
   в System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type)
   в ASC.Core.Notify.Jabber.IReverseJabberService.SendState(String from, Byte state, Int32 tenantId, String domain)
   в ASC.Xmpp.Server.ReverseJabberServiceClientWcf.SendState(String from, Byte state, Int32 tenantId, String domain)
   в ASC.Xmpp.Server.ReverseJabberServiceClient.SendState(String from, Byte state, Int32 tenantId, String domain), Удаленный сервер возвратил ошибку: (500) Внутренняя ошибка сервера.

Ошибка видна, но что с этим делать ?

В основном логе:
Код: Выделить всё
2015-03-23 12:43:32,215 WARN  [384] ASC.ActiveDirectory.ADDomain - Can't get Domain DistinguishedName. May be current user has not needed permissions. System.Runtime.InteropServices.COMException (0x80005000): Неизвестная ошибка (0x80005000)
   в System.DirectoryServices.DirectoryEntry.Bind(Boolean throwIfFail)
   в System.DirectoryServices.DirectoryEntry.Bind()
   в System.DirectoryServices.DirectoryEntry.get_NativeObject()
   в System.DirectoryServices.DirectoryEntry.InvokeGet(String propertyName)
   в ASC.ActiveDirectory.ADDomain.GetDefaultDistinguishedName(String server, Int32 portNumber)

AD у меня не используется. Так что ничего криминального.
ArLex
 
Сообщения: 18
Зарегистрирован: Пн мар 23, 2015 7:23 pm

Re: Не работает чат через веб-клиент

Сообщение ArLex » Пн мар 30, 2015 3:33 pm

Проверил на Win 8.1 Pro x64. Все работает без проблем.
Почему тогда на Windows Server 2012 R2 вебклиент не соединяется с jabber-сервером ?
ArLex
 
Сообщения: 18
Зарегистрирован: Пн мар 23, 2015 7:23 pm

Re: Не работает чат через веб-клиент

Сообщение crazy_duck » Ср апр 01, 2015 8:19 am

Базу данных не переименовывали?
У меня была такая фигня, когда переименовал базу данных.
crazy_duck
 
Сообщения: 75
Зарегистрирован: Пн мар 02, 2015 10:17 pm

Re: Не работает чат через веб-клиент

Сообщение ArLex » Ср апр 01, 2015 8:35 am

crazy_duck писал(а):Базу данных не переименовывали?
У меня была такая фигня, когда переименовал базу данных.

В mysql - "onlyoffice". При установке OnlyOffice я еще выбрал другое размещение - на более быстром диске. Но это никак не должно влиять.
Еще я делал много правок в конфигах - исправил везде localhost на свой_домен. Вебклиент чата, насколько я понимаю соединяется с сервером так же как и любой клиент типа QIP и т.п., т.е. по внешнему IP. Или я не прав ?
ArLex
 
Сообщения: 18
Зарегистрирован: Пн мар 23, 2015 7:23 pm

Re: Не работает чат через веб-клиент

Сообщение AnaMih » Ср апр 01, 2015 8:50 am

To: ArLex
Попробуйте, пожалуйста, выставить enable-signalr в false в Джаббер-сервисе. Возможно, ошибка возникает из-за проблем с соединением.
Аватара пользователя
AnaMih
 
Сообщения: 630
Зарегистрирован: Пн авг 25, 2014 10:15 am

Re: Не работает чат через веб-клиент

Сообщение ArLex » Ср апр 01, 2015 9:18 am

AnaMih писал(а):To: ArLex
Попробуйте, пожалуйста, выставить enableSignalr в false в Джаббер-сервисе. Возможно, ошибка возникает из-за проблем с соединением.

Этого параметра нет в конфигах. Куда его добавить ?
ArLex
 
Сообщения: 18
Зарегистрирован: Пн мар 23, 2015 7:23 pm

Re: Не работает чат через веб-клиент

Сообщение AnaMih » Ср апр 01, 2015 11:00 am

c:\Program Files\Ascensio System SIA\ONLYOFFICE\Services\Jabber\TeamLabSvc.exe.Config
<add key="web.enable-signalr" value="false" />
Аватара пользователя
AnaMih
 
Сообщения: 630
Зарегистрирован: Пн авг 25, 2014 10:15 am

Re: Не работает чат через веб-клиент

Сообщение ArLex » Ср апр 01, 2015 11:15 am

AnaMih писал(а):c:\Program Files\Ascensio System SIA\ONLYOFFICE\Services\Jabber\TeamLabSvc.exe.Config
<add key="web.enable-signalr" value="false" />

Не помогло.

Код: Выделить всё
2015-03-23 17:20:30,429 ERROR [171] ASC.Xmpp.Server.ReverseJabberServiceClient - Service Error: Тип содержимого text/plain ответного сообщения не соответствует типу содержимого привязки (text/xml; charset=utf-8). При использовании особого кодировщика необходимо правильно реализовать метод IsContentTypeSupported. Первые 89 байтов ответного сообщения: "An error has occurred: {"code":"ECONNREFUSED","errno":"ECONNREFUSED","syscall":"connect"}".,

Из-за чего все-таки эта ошибка ?

Я проверил версию NetFramework на домашней машине и на сервере - одна и та же: 4.5 (а в диспетчере IIS/пулы приложений отображается 4.0.30319)
Только на win8.1 все работает, а на сервере нет. Я уж подумываю пора еще сервак разворачивать только на debian...
ArLex
 
Сообщения: 18
Зарегистрирован: Пн мар 23, 2015 7:23 pm

След.

Вернуться в Проблемы с оповещениями

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 2